GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Fog lights not working!!

    Hi all... my name is Terry and I just brought home my 2001 GMC 2500HD crew cab long bed diesel yesterday.... so Proud!!! this is to replace my 95 GMC 2500 short cab long bed gas truck. Holy crap, that's a long truck!! Longer than my 15 passenger Chevy van...wow...

    My question is the button is on the console, and the fog lights are on the truck, but not working, and no display indicator light lights up on dashboard, when I push the button. And, as previously stated, no fog lights light up. Can I get some advise?? thanks

  2. #2
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    Ok first... Did you check the bulbs?? Fuse? it is a older truck and the stock Fogs are more for looks then light..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  3. #3

    Default

    ok... first checked the fuse with probe light, it lights up, and extra measure, pulled it and visually checked it, it looks good. Next, pulled the bulb, it is fine also. Next, switched relay in engine bay with same exact relay from inside fuse panel driver's side, still no fog lights. So, I really don't want to rip into the dashboard, but what I haven't checked, and not really sure how to, is the switch itself.

    It's not so much that I want crappy fog lights, it's more to do with I want everything to work properly on my 'new' truck! And, I do like having fog lights.... they look cool and help when it's foggy, right? Hope this forum can help me! And thanks for the reply Enkeiavalanche...

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    Can you check the wires going to the fog light? Probe them? see if they are getting power

  5. #5

    Default

    Don't know about your truck; but in some trucks, the indicator light turns on when the relay operates (of course, the lights should as well). Put your finger on the relay while someone operates the switch, you should feel the relay operate.

    BTW, the low beam headlights need to be on before the fogs will work.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  6. #6

    Default

    I forgot to add that... yes I probed them with test light, nothin'... made sure to test them, then press the switch and test them again, no power to the bulb..

    - - - Updated - - -

    also, was doing my checking with the lights on, not highbeams, and I do not see and indicator light coming on in the truck. My friend has an '03 with same fog light button in the same spot as this '01 and his has a small amber light that lights up in lower left corner next to the fog light button.... I so far have not seen any amber light coming on in mine.. if that helps...

  7. #7

    Default

    UPDATE: FOG LIGHTS NOW WORKING!!

    After much investigation, turns out the switch must be depressed and pushed slightly to the left towards the driver's door and then it works... My conclusion therefore is a poor contact or something.. but persistance, and patience has paid off and I'm glad to say everything on my new truck works! Thanks to all who posted with help/suggestions...Terry

  8. #8
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    No problem thats what we are here for....

Similar Threads

  1. 92 Sub Tail lights not working
    By kepster in forum GM Electrical Tech
    Replies: 16
    Last: 12-11-2012, 12:46 AM
  2. Done lights/map lights not working After dash pulling
    By Jimmy Lee in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last: 08-11-2011, 08:41 AM
  3. Tail lights not working
    By carlsauction in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 05-28-2010, 08:39 PM
  4. Courtesy lights not working
    By RONNYB in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 03-02-2010, 02:23 PM
  5. '97 dash lights not working
    By safetyfast in forum Chevy C/K Truck Forum
    Replies: 7
    Last: 09-12-2009, 08:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •