GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 12

Hybrid View

  1. #1

    Question Low Air Flow in Front Heater

    Hello,

    I am new here, signing up to figure out what I did wrong in repairing the heating on my 1996 Suburban C1500. I am scratching my head, please help.

    My fan blower was making a nasty screeching noise in cold weather, plus the medium 1 fan speed setting was not working. I took out the blower motor, lubricated it, cleaned out the area around the blower motor (pretty clean really for a 16 year old car). Blower works fine now, no noise. Then I changed the A/C & heater fan control switch behind the dash, now all fan speed settings work. So far so good.

    Now with everything put back in place the air flow through any of the vents is not a fraction of what is was before! I checked the air-flow direction actuator: it seems to work, a bit comes out of the defroster when directed there, and also from the other outlets. The blend door also seems to work: I can adjust the temperature of the bit of air air coming out. I took off the cover underneath the heater core (not too hard if done with a very thin 1/4 inch ratchet), and the inside was super clean. The flap door for inside circulation (close to the blower motor) seems to be working too. So what the hell could possibly be restricting the air flow? Is there another flap door I don't know of? Is there a flap door in the air flow direction actuator that could be stuck?

    I ordered a replacement for the A/C, heater, blender control console, since that seems to fail often, but I'd rather not put in a new $ 140 part if that is not the culprit.

    Any suggestions from people who have more experience with this than I do -- this is the first time I ever did anything with the heating system.

    Thanks!

  2. #2

    Default

    Without being there to listen, I'm thinking the blower motor is the problem. It noisy and you lubed it. Did you take it apart to do this?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Quote Originally Posted by RayVoy View Post
    Without being there to listen, I'm thinking the blower motor is the problem. It noisy and you lubed it. Did you take it apart to do this?
    Thanks Ray,

    Without taking it apart I sprayed a bit of 4WD at the two endpoints of the shaft of the blower motor, using a long flexible plastic nozzle. The fan seems to be blowing full blast to me, but of course I've never see it operate before the lubrication. Would be nice if that is the problem, because that motor is easy to replace. Any thoughts?

    Love that car! I have five kids and two dogs and we take it everywhere, skiing, hiking, camping.

  4. #4

    Default

    Are you stating that air is coming out of all vent? This can usually be fixed by turning on the A/C. This will force the defroster door closed and only allow the front or foot vents to work. Try it a few times. Worked when it happened on my truck and has worked on others from this gen on the site.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  5. #5

    Default

    What I meant to say is that the air comes from any vent (floor, dashboard, window) that I direct it to, but only in a trickle. I tried the A/C remedy (thanks Conlan), but it did not work. I also replaced the fan motor (not very expensive really), but it makes no difference, same sound, same fan speed.

    So what else could be wrong? Something stuck in the flow direction actuator? Something a new A/C heater, fan, etc console could fix?

    Thanks again!

Similar Threads

  1. Replies: 0
    Last Post: 09-12-2012, 09:30 PM
  2. heater/ac problem {mostly heater!! help its getting cold :(!!!}
    By notpilbrisk in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 10-03-2011, 09:28 PM
  3. 1998 silverado leaking coolant near heater hoses on heater core
    By BigTirez in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 03-21-2011, 09:43 AM
  4. 04 Z71 heater issues. AC sometimes blows hot, heater temp is lukewarm
    By yak in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 11-04-2010, 10:11 AM
  5. front heater suburban
    By EdPDX in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 12-04-2009, 12:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •