GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24
  1. #21
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default

    Yeah, a very poorly installed remote start wiring job. When I was under there looking for the flasher relay I noticed everything was a cluster mess. Nothing was mounted where it was supposed to be, everything was just loose, wires everywhere.

    I really wish I would have had time to work on it myself so I could get some experience doing that kind of work.
    1999 Chevrolet Suburban LS K1500
    1991 Chevrolet S10 4.3L 4x4
    2005 Suzuki Forenza (GM/Daewoo)

  2. #22
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    I guess you did the correct thing by having , that shop fix up the hacked wiring. not a job for learning.

    with what you stated on the condition , this needs time to make right.

    many of these alarms/remote starts create many owner issues with this type install which is very common being screwed up.

    good luck .

  3. #23
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default

    Your probably right.
    1999 Chevrolet Suburban LS K1500
    1991 Chevrolet S10 4.3L 4x4
    2005 Suzuki Forenza (GM/Daewoo)

  4. #24
    Sr. Engineer FergusonT's Avatar
    Join Date
    May 2010
    Location
    Southwest Michigan
    Posts
    398

    Default

    So far in the past few months this truck has had the fuel pump/filter, plugs/wires, intake gaskets, alternator, ignition switch, ignition lock cylinder housing, fuel pressure regulator, battery........I also have an upper ball joint and front shocks to install...oh and a new fog light to install......and replace the multifunction switch (no turn signals/flashers-already replaced the flasher relay). hm what else. I really should do a new slip yoke because of the annoying clunk.
    1999 Chevrolet Suburban LS K1500
    1991 Chevrolet S10 4.3L 4x4
    2005 Suzuki Forenza (GM/Daewoo)

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Passlock relearn
    By conman13 in forum GM Electrical Tech
    Replies: 0
    Last Post: 09-29-2011, 06:41 PM
  2. Please, NEED HELP ASAP, gm passlock?
    By jaden5012 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 02-18-2011, 12:14 PM
  3. 04 Colorado passlock/no start
    By nj110 in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 14
    Last Post: 05-24-2010, 06:09 AM
  4. Passlock
    By aboston in forum GM Electrical Tech
    Replies: 10
    Last Post: 01-05-2010, 05:49 PM
  5. does the Passlock II do this
    By EdPDX in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 01-06-2009, 09:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •