GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1
    Sr. Apprentice Sir Koscoe's Avatar
    Join Date
    Feb 2013
    Location
    Byesville, Ohio
    Posts
    48

    Default Rough idle when cold

    Now that I have the break issues fixed it's on to my next project. In the mornings when it is cold out the truck idles rough. Roughly like I am pressing the gas and letting off until it gets warm then it runs fine. Could this be a dirty MAF and/or TB? My brother said his 99 did this same thing and cleaning the TB helped. I know it will be a good idea to clean them anyway since the truck has 184k on it. Just wanted your thoughts. Thanks.
    If you think you can do a thing or think you can't do a thing, you're right.--Henry Ford

  2. #2
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,447

    Default

    using throttle body cleaner and removing the IAC and then clean the parts will help idle issues.I use a tooth brush and a cloth to clean and wipe out the carbon deposits as much as possible.
    the PCV and the crankcase hoses need to be checked/replaced. the ECT could be defective @180,ooomi I would replace it.

    pcm uses MAP/MAF/ECT to adjust cold start idle,,, a leak/bad PCV in the crankcase venting or other vacuum leak throws off these programed PCM idle control. also leaks in the air intake after the MAF.

    I would get crc MAF cleaner and clean the small maf sensing wires. just a small amount of spray on the wires is all that is needed. do not touch the wires.

    hold the throttle body open to dry out the throttlebody cleaner before starting. If its cold out use a hair dryer to evap the solvent before starting.

  3. #3
    Sr. Apprentice Sir Koscoe's Avatar
    Join Date
    Feb 2013
    Location
    Byesville, Ohio
    Posts
    48

    Default

    Quote Originally Posted by j cat View Post
    using throttle body cleaner and removing the IAC and then clean the parts will help idle issues.I use a tooth brush and a cloth to clean and wipe out the carbon deposits as much as possible.
    the PCV and the crankcase hoses need to be checked/replaced. the ECT could be defective @180,ooomi I would replace it.

    pcm uses MAP/MAF/ECT to adjust cold start idle,,, a leak/bad PCV in the crankcase venting or other vacuum leak throws off these programed PCM idle control. also leaks in the air intake after the MAF.

    I would get crc MAF cleaner and clean the small maf sensing wires. just a small amount of spray on the wires is all that is needed. do not touch the wires.

    hold the throttle body open to dry out the throttlebody cleaner before starting. If its cold out use a hair dryer to evap the solvent before starting.

    Thanks Cat. The truck runs good after it warms up, so i will clean everything when it gets a bit warmer out unless the issue becomes worse.

    Dumb question, but will this affect my MPG's?

  4. #4
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,447

    Default

    lets say you have a failure with the crankcase vent system which causes a loss of the calibrated measured Vacuum of an amount GM used to program the PCM. then the PCM will see that the engine is with a lean condition now it opens the injectors for a longer time to correct to get the 14.7 to 1 air to fuel ratio.

    this causes lower MPG.

    after the cleaning and checking for any vac failures the engine should idle smooth and with the maf cleaned faster throttle response

  5. #5
    Sr. Apprentice Sir Koscoe's Avatar
    Join Date
    Feb 2013
    Location
    Byesville, Ohio
    Posts
    48

    Default

    Quote Originally Posted by j cat View Post
    lets say you have a failure with the crankcase vent system which causes a loss of the calibrated measured Vacuum of an amount GM used to program the PCM. then the PCM will see that the engine is with a lean condition now it opens the injectors for a longer time to correct to get the 14.7 to 1 air to fuel ratio.

    this causes lower MPG.

    after the cleaning and checking for any vac failures the engine should idle smooth and with the maf cleaned faster throttle response

    Awesome. I can't tell if the truck has a vac leak of a small miss. You can hear it while I am on the throttle. I need to give the engine bat a really good check once it warms up outside. I don't want to freeze my boys off since I have no garage of my own to work in.

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,447

    Default

    looks like the nasty cold is not coming back too soon 40's up here. the 3 ft of snow we got last week is down to about a foot. nice weather now.

  7. #7
    Sr. Apprentice Sir Koscoe's Avatar
    Join Date
    Feb 2013
    Location
    Byesville, Ohio
    Posts
    48

    Default

    my buddy and his family drive pulling trucks so I could work in his garage, but he and his wife are having thei first baby this week so I don't want to bother him.

    it snowed here yesterday and a lady asked me hwo the roads were, it maybe snowed 1/8" inch. People get too bent out of shape when they see snow.

  8. #8

    Default

    I have a 99 with the same issues, cleaned maf and everything else, put in new intake manifold gaskets as I have heard that can cause the issue, new plugs and wires, new pcv valve and fuel filter, new air filter, still have the same issue. Seems this is a pretty common problem after reading through the forums, I have decided might be easier to live with it at this point...unless anyone can point to a resolution that has solved without fail. The dealer said it could be multiple sensors etc, but I hate throwing money blindly at the problem.

  9. #9
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,447

    Default

    in your case I would replace the ECT costs about 20.oo . @ 100,ooo plus miles they start to go out of cal.spec.ECT is a big part of the cold start PCM process.

    if the PCM thinks its 70 deg f when its 20 deg f, cold start is not good.

  10. #10

    Default

    Instead of shotgunning track down somebody with a scanner and watch the sensor data in real time while also monitoring engine temp with a temp gun. Between the maf, iac, tps and upstream sensors you should be able to tell if it is a vacuum leak. I have said this before and will prob say it again but the intakes do warp so just putting gaskets on do not fix the issue. Between high miles, not torqueing the bolts properly and plastic fatigue in the shop we always recomend the dorman intake kit. All of the vortec engines have this problem as well as the 3800's and all ford v6's with plastic plenums.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


Similar Threads

  1. Rough Idle On cold mornings ~ 2002 Chevy Silverado Z71
    By 23shink in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 11-14-2012, 01:39 PM
  2. Rough/Hard Idle at Cold Start, fine after ~1min
    By MightyMax in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 10-13-2010, 12:21 PM
  3. rough idle
    By Okimaw in forum GM Powertrain
    Replies: 0
    Last: 03-14-2010, 08:29 AM
  4. rough idle
    By BigE in forum Member Introductions
    Replies: 0
    Last: 05-07-2009, 07:01 PM
  5. rough idle
    By RLawns in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 02-03-2009, 12:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •