GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Tail lights not working

    Hey guys,

    I have a '94 z71 stepside I am having electrical problems with. When I turn on my headlights, I lose brake lights and tail lights. Also when I press my brake pedal, my turn signal speeds up like I have a bulb blown. All fuses are good to my knowledge plus I don't think this could be a fuse since so many different circuits are involved. The stereo was stolen out of this truck before I purchased it but it looks like the factory wiring harness was left in the truck. I have not replaced the stereo as of yet. Could this be caused by the turn signal switch since all systems seem to run through this or something else? Any help would be greatly appreciated. Also, there is some aftermarket wiring in place for a stereo amp and a CB radio. I have visualized the wiring for these the best that I can and have not found any bare wires or shorts. Thanks again for the help.

  2. #2

    Default

    Welcome to the club.

    I think you have a ground problem, and, I think it is in the rear of the truck.

    All rear lights are connected to ground, as long as there is not a lot of current flowing through the poor ground, one set of lights will work, add the current flow for a second set and the ground resistance increases and slows the current.

    As it appears common to all lights at the rear, I suspect the bed to chassis ground strap.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Bad grounds will play havoc with all kinds of systems. You're lucky that only your lights are being affected right now. If you find and fix the bad ground, you not only could fix the lights, but hold off any other problems that may be developing due to voltage fluctuation issues.

    Good luck.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

Similar Threads

  1. 92 Sub Tail lights not working
    By kepster in forum GM Electrical Tech
    Replies: 16
    Last Post: 12-11-2012, 12:46 AM
  2. Tail Lights not working!!
    By dodger32 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 11
    Last Post: 10-28-2012, 06:13 PM
  3. 82 K10 Tail and Reverse Lights Not Working!
    By ahobson1 in forum Chevy C/K Truck Forum
    Replies: 7
    Last Post: 06-20-2010, 08:08 PM
  4. Tail lights not working
    By carlsauction in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last Post: 05-28-2010, 08:39 PM
  5. Rear tail lights not working
    By floutlaws in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 08-22-2009, 10:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •