GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 5.3 Liter Vortec Engine problem

    I have a 2002 Suburban with the 5.3 liter vortec and I am having issues with it running rough when cold and the "service engine soon" light coming on periodically for a matter of a day or two, go off again for a while, then coming back again. Can't seem to make up its mind if it happy or not! A buddy of mine has an analyzer and when he plugged it in to check the code it was showing, the analyzer could not find that there was a computer module in the circuit.

    Anyone out there know what my issue(s) might be?

    I assume that if the computer module was bad or dead, the "service engine soon" light would not light up, or would just stay on? That said, when it is cold it kinda runs like the computer is not controlling the choke or other cold running features correctly. Could it just be a fuse that runs the computer being bad?

    At a loss...

  2. #2
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    Welcome How many miles are on the truck now? Have you done anything to it?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  3. #3

    Default

    It has a little over 185,000. Completely stock.

  4. #4
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    Did the analyzer come on at all or just not work? It needs power and it could be the fuse was blown. I think the cigar fuse provides power to the OBDII connector. If it is bad then replace and try it again.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  5. #5

    Default

    Thanks guys for responding... I am new to the site and an engineer by trade so I periodically do some of my own maintenance and repairs to gain experience and of course to save money.

    The analyzer worked fine, it just could not establish communication with the computer module. My buddy said that it was like there was no computer in the vehicle. Are you thinking the computer itself is not getting power or that there is no power available at the connector?

    If the computer was not working at all I could see that being the reason for my cold starting issues but would the vehicle run at all without power to the computer?

    I will check all my fuses today and see if any are blown. I know that all of my cigar lighter sockets work because we use them all very regularly since my family is obsessed with electronics!

Similar Threads

  1. 454 ( 7.4 liter ) VORTEC
    By DAREDEVIL in forum Engines Classifieds
    Replies: 4
    Last: 05-14-2013, 02:10 PM
  2. Buying New 2012 Truck F250 6.2 Liter Gas vs. Sierra 2500HD 6 Liter Vortec
    By Todd00601 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last: 05-08-2012, 10:49 PM
  3. 8.1 liter Vortec lift.
    By Jason2325 in forum Chevy Truck Talk & GM News
    Replies: 0
    Last: 02-24-2012, 12:35 PM
  4. 5.7 liter Vortec Misfiring badly
    By SuperMatt in forum GM Powertrain
    Replies: 19
    Last: 07-14-2009, 06:50 PM
  5. Ward's AutoWorld honors Flint Engine South 3.6-liter V-6 engine - MLive.com
    By ChevyFan in forum Chevy Traverse Forum (GMC Acadia, Buick Enclave)
    Replies: 0
    Last: 01-16-2008, 12:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •