GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 1993 c1500 fuel problem

    my 93 1500 just quit running in driveway and does not have fuel coming out of injectors. have fuel to carb and 12v at injector wire but no pulse when starting. could it be computer problem, if so, is there a way to check it before replacing it? i have replaced fuel pump, filter, fuel pressure regulator. i dont wanna replace ecm if there is no signal going to ecm. ive heard there are few other sensors that could cause fuel shut down. i just dont wanna keep replacing parts if not the problem. any help would be much appreciated.

    - - - Updated - - -

    also had ignition control module checkd....its good. ive talked to a few techs and all telln me its the computer.....plz lemme know if there is anything else i can check before i go replacing computer

  2. #2

    Default

    Like no fuel at all?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  3. #3
    Newbie joshmodelskidoo's Avatar
    Join Date
    Mar 2013
    Location
    between big rapids and grand rapids michigan
    Posts
    4

    Default

    bad or dirty injector maybe?

  4. #4

    Default

    Fuel relay switch under the black cover on the fire wall next to all the grounds? Or the fuse for it right on the other side? Have you checked those?
    94 Chevrolet K1500 4x4. 5.7L 350, 5-speed (AKA Betty) Or Rust Bucket...depends on if I'm mad at her.

  5. #5

    Default

    See if you've got any codes. The computer actually does have trouble codes for both a failed ECM and PROM.
    ...
    ....

  6. #6
    Jr. Apprentice
    Join Date
    Mar 2013
    Location
    Huntsville, alabama
    Posts
    18

    Default

    how do you know you have fuel to the Carb? is the pump kicking on when you turn the key into the "on" position?

    The computer should throw a code for bad ECM. The pump may still be bad, even if it is new (ask me how I know).

    An easy way would be to try someone elses computer that is the same as yours, but not many people want to give those up easily.

    Good luck. Hope you figure it out soon.

  7. #7

    Default

    Actually do a fuel pressure test and make sure that your getting the correct fuel pressure first. Also make sure that if your not getting any fuel pressure at all or if your pump isn't turning on that when your key is ON your getting 12v to the fuel pump. Its possible that the ecm is bad because it does control the fuel pulses. Cross pins A and B on the ecm plug in under the dash on the driver side with key on it should flash a code 12 meaning ecm normal, if it flashes other codes find out what they are. Below is the ECM pinout, tkae a paper clip and bend it to cross pins A and B and your CEL will flash. So say your looking for code 12 it will display like this.. Flash....flash flash......repeat 4 more times then a longer pause then it will display other codes or just repeat code 12 again if there are no other ones. So if it was code 55 indicating ecm error is would flash like this....... flash flash flash flash flash.......flash flash flash flash flash.


    Good luck, hope this helps a little!


    Here is the GM OBD1 code list for flash codes if you need it... http://www.gmtuners.com/OBD1_DTC.htm
    1995 C1500 4.3L 2WD. JET TBI Spacer, JET stage 1 chip, 10mm Taylor custom wires, Pulstar Iridium Pulse Plugs.
    260k miles and still going strong...

Similar Threads

  1. 99 C1500, 5.7 fuel mileage
    By 59diesel in forum Chevy C/K Truck Forum
    Replies: 4
    Last Post: 04-25-2012, 07:41 AM
  2. 1993 GMC suburban C1500 2x4...need axle help
    By Zombie Killer in forum GM Powertrain
    Replies: 4
    Last Post: 03-09-2011, 08:39 PM
  3. Replies: 1
    Last Post: 10-25-2009, 09:53 AM
  4. Please help 1993 Yukon problem
    By redzbutterfly in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 03-15-2008, 12:14 PM
  5. 1993 C1500 Suburban FS
    By kknobl in forum General Classifieds
    Replies: 0
    Last Post: 10-24-2007, 08:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •