GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 99 Suburban with issues at start, low idle and wants to die

    My 99 Suburban has an issue at start up. When starting, it has a low idle and without giving it a little gas it will die. Seems that after it warms up it gets better and runs normal. If I turn the motor off after its warmed up it will sometimes resort back to a rough start and sometimes not.
    I do not have a check engine light on. Not sure what the issue might be especially since sometimes it will correct its self after warm.
    A couple of my thoughts are fuel filter, throttle body needs to be cleaned, or distributer. Any other ideas?

    Its a 99 Burb, 5.7 liter, 4x4.
    Chevrolet Avalanche 1500 Z71
    5.3 Liter
    4X4

  2. #2

    Default

    So I switched out the cap and rotor yesterday and the first fire up was perfect, the rest back to the same ol same ol. I did notice that the inyards of the distributer look rusty and not so clean. I also noticed that when I pulled out on the street and slowly gave it throttle, it gained rpm and sped up slightly on its own.

    ANy ideas on that?
    Chevrolet Avalanche 1500 Z71
    5.3 Liter
    4X4

  3. #3

    Default

    Have you tried cleaning the throttle body? Carbon build up around and behind the throttle plate will cause erratic idle air bleed thus fluctuating idle.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

  4. #4

    Default

    Thanks for the tip bazar01. I'll pick up a bottle of throttle body cleaner on the way home tomorrow. I looked up a couple of videos of the process and it makes sense. If nothing else i'm sure it needs to be done!
    Chevrolet Avalanche 1500 Z71
    5.3 Liter
    4X4

  5. #5

    Default

    Among the first things I'd check would be to check the fuel pressure.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  6. #6

    Default

    Here is an update.
    I finally got some time and cleaned the throttle body. It was dirty as all get out when I looked at it. I gave it a once over and got it looking fairly clean and fired the Burb up. Seems to have fixed my problem. As of now I have driven around 20 miles and turned it off and re started it around 20 times. So far she starts up like she should and does not drop idle speed.

    Thanks for the tip bazar01!
    Chevrolet Avalanche 1500 Z71
    5.3 Liter
    4X4

Similar Threads

  1. 2003 Suburban - Low Idle issues
    By bladerunner77 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 03-06-2013, 03:12 PM
  2. Crazy Idle Issues
    By MTM in forum GM Powertrain
    Replies: 9
    Last Post: 09-04-2012, 10:51 PM
  3. 89 idle issues
    By k9ulan in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 05-23-2012, 03:47 PM
  4. issues with idle
    By BigRed2500 in forum Performance & Fuel
    Replies: 0
    Last Post: 08-29-2008, 10:07 AM
  5. Idle Issues
    By trivers in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 13
    Last Post: 11-17-2007, 01:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •