GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default New y-pipe problems

    Hope everyone isn't pissed at the world for the hour forward last night, but happy Sunday regardless. I recently had a Flowmaster y-pipe with dual cats to replace the factory set up as the check engine light was on for bad cats. So far I noticed much better flow, but also a strange metallic sound. When driving only, it sound like someone is shaking a can of spray paint. It is very noticeable when I don't have the radio on. After checking for clearance issue, I could not spot anything. This only started after the installation of the y-pipe (local muffler shop installed it). This morning I took I to one of their sister stores and the mechanic said he could not find anything that could be causing the sound. He check the clearance and even tapped everything with a hammer and still nothing. I'll be calling Flowmaster on Monday to report the issue. Kinda ranting here but does anyone have an idea what could possibly be creating the sound?

    - - - Updated - - -

    I'll give them a call in the a.m. tomorrow. Didn't know if anyone had a similar run in or an idea.
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  2. #2
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default

    After installing the second y-pipe with cats from flowmaster I still have the same rattle. I put an engine stethoscope to the cats and flanges while idling and can not hear anything. I can only hear the rattle while moving. The clearance is good and I double checked the bolts, but can not pin point the rattle. Anyone have any ideas?
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  3. #3

    Default

    Could it be a muffler with something trapped inside, or with a loose baffle?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default

    The sound seems to be right under the floor boards. And also I did not have this problem until immanently after the ypipe swap
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  5. #5

    Default

    Quote Originally Posted by KyleZ71 View Post
    And also I did not have this problem until immanently after the ypipe swap
    Mis-understood, thought you have changed the whole exhaust as well.

    Ok, maybe the installer forced the old pipes and muffler out of alignment, did you check the complete exhaust for clearance?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  6. #6
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default

    I'll have to recheck after class tomorrow. If that isn't the problem I had thought maybe the shields on the cats are poor quality and thats whats rattling
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  7. #7

    Default

    Try jamming a piece of wood into the space between the cat and the shield. don't force it, just enough to stop any vibration.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  8. #8
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default

    Good idea. I'll have to give that a try
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  9. #9
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    855

    Default

    Took it to the garage yesterday and they did what no other garage would do. They lifted it, and then put it in gear so they could hear the rattle, as it only rattles when moving. The good news is we've pin pointed the problem, bad news is they believe its the transfer case.

    During the winter months, I had a severe allergic reaction and went to the pharmacy in 4wd. Since I need to get benadryl, now I did not hold back on the gas. I heard a loud pop during that time, but I guess it took until installing the y-pipe until the rattling started
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

Similar Threads

  1. Exhaust Links and Articles H pipe X pipe Mufflers
    By Dr_Zero in forum GM Powertrain
    Replies: 9
    Last Post: 10-08-2010, 12:37 PM
  2. x pipe
    By sharpshooterusmc in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 05-05-2010, 05:07 PM
  3. X pipe!
    By rackchaser71 in forum Performance & Fuel
    Replies: 3
    Last Post: 03-31-2009, 08:48 AM
  4. h-pipe ?
    By vncj96 in forum Chevy Truck Accessories
    Replies: 1
    Last Post: 04-26-2008, 04:32 AM
  5. WTB Y pipe 93 4x4 350
    By homer911 in forum General Classifieds
    Replies: 1
    Last Post: 09-17-2007, 12:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •