GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1

    Default Service Ride control

    greetings all

    i have a 2000 chevy suburban 2500 with about 81000 miles and the service ride control light has just come an and will not go off. any ideas, thanks in advance.
    2000 Chevy Suburban
    2500
    :glasses:Joey:party:

  2. #2

    Default

    ever get an answer to this problem. I have a 2000 suburban and the service ride control has been on for years. 150000 miles. I think I need shocks anyway but not sure if this will fix the problem.

  3. #3

    Default

    Just still researching this issue and thought I'd bump the thread . Must not be a very common issue as its hard to get a straight answer anywhere I look.

  4. #4

    Default

    what is "service ride" ????
    Ryan

    2002 Jeep Wrangler Sport 4x4 (the Yellow Jacket)
    4inch suspension 3inch body
    Straight 6 (383 Stroker within a year)
    36inch SuperSwamper TSL.
    105,000
    Detroit Loccers
    Daily Driver Weekend Wheeler
    much more...

    2004 Sierra crew cab, 2wd, 5.3 V8
    2inch Daystar Leveling kit
    single dumped Flowmaster 40 sieries exaust(removed)
    Mb Blitz Chrome wheels
    Leer Bed Cover(for sale)
    50k miles
    :glasses:




  5. #5

    Default

    Its "service ride control" and thats what I am trying to find out myself. I believe its something to do with the shocks. I know I need shocks but just wondering if there is anything else to this. I know on my vette I just look up an issue and there are all kinds of people who have had the same problems and Its very easy to track down and fix. I guess the suburban does not have such an avid following. Just trying to avoid the dealer and dont own a diag. tool.

  6. #6
    Master Mechanic
    Join Date
    Oct 2008
    Location
    Brandon, FLA
    Posts
    747
    Blog Entries
    1

    Default

    Gentlemen;

    Here is what I have found on this issue, please be advised that this is being brought to us from another site to which I have NO affiliation with, just an extensive search on the issue, as my 02 Burban
    has the feature to which I want to be aware of in case of future problems or issues. The following:
    2001 Suburban 5.3 4x4 with Autoride. Sent to Chevy Experts February 06 01:20 PM ... Service Ride Control Message Displayed, DTC C0580 Set (Replace Right ...
    chevrolet.justanswer.com/questions/127ul-2001-suburban-5-3-4x4 - Similar pages
    (You can access by using Google and in the search put "service Ride Control - Chevy Suburban")
    This has a very lenghty write up and a good one to boot. I hope this at the very least provides a start
    to correcting your problems. The Burban is new to me on repairs, most are still general repairs with deductive reasoning, some I will need to learn, but learning keeps the mind alive, even if the body has been banged up, right!
    JMoney02

  7. #7

    Default

    that's your autoride- has sensors on each wheels (1500) has compressor to pump air to your rear shocks- if you see the message-check your fuse marked RTD (real time damping).
    Last edited by newdriver; 10-28-2008 at 10:21 PM.

  8. #8

    Default

    thanks, during my research i did find out that it does have something to do with the shocks and the auto levleing system.
    2000 Chevy Suburban
    2500
    :glasses:Joey:party:

  9. #9
    Jr. Engineer Jacqson's Avatar
    Join Date
    Jan 2009
    Location
    North Vancouver, BC
    Posts
    221

    Default

    Quote Originally Posted by joh1168 View Post
    greetings all

    i have a 2000 chevy suburban 2500 with about 81000 miles and the service ride control light has just come an and will not go off. any ideas, thanks in advance.
    There is some kind of malfunction in the Autoride system which is sending you the error code. I have successfully removed the Autoride from my Suburban. If you have any questions, let me know and I will post the threads for you.

  10. #10

    Default

    yes. please help! I need to remove this option. Thanks

Page 1 of 3 123 LastLast

Similar Threads

  1. 2001 Silverado with Ride Control Issue (I don't want it)
    By jpking78 in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 04-02-2010, 06:29 PM
  2. How to bypass ride control feature for new shocks
    By xracer in forum Lifted & Offroad Suspension
    Replies: 1
    Last Post: 01-20-2010, 06:42 PM
  3. 2003 1500HD Ride Control Shocks
    By HDSilveradoDave in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 10-25-2009, 11:53 AM
  4. service ride control problem
    By thomas in forum Member Introductions
    Replies: 0
    Last Post: 03-15-2009, 02:04 PM
  5. 2002 Yukon XL Denali Ride Control
    By Chevrolade in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-06-2008, 10:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •