GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 3 of 4 FirstFirst 1234 Last Post byLast Post by
Results 21 to 30 of 39
  1. #21

    Default

    Quote Originally Posted by geo1 View Post
    thanks for tsb info,i left rear foam in,will remove asap,back to po300 on yees v rod,any symptoms?i had none,took a month before k.s. code came up

    - - - Updated - - -

    good question,say the vehicle was parked down hill,would water wick thru from rear onto valley?
    ^ good point I parked my truck on a slight incline nose down . also I remember it rained a lot that night before my truck took a dump on me
    2005 chevy reg cab 2500 6.0l
    bds 7" ntbd high clearance kit
    7%tint 15% Windsheild tint

  2. #22
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    o.k. to j cats info on t.s.b,i just pulled my rear foam out,no big deal,it was shot,while there i felt valley floor,it was dry.yeha,i could only reach so far,but happy with results,now harness is right there for k.sensors,would it be wise to push/pull lightly to try for a better connection?they are a pop on connector,j cat?info?

  3. #23

    Default

    ok I'm stumped I really wanna figure this out . it's a loud knocking vibrating my whole truck and does NOT go away after warm up . first thoughts that pops in your guys head ?

  4. #24
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    try pulling a spark plug,one at a time,and run it,this way you can isolate to a specific cylinder,otherwise pull off valve covers,look for valvetrain failure

  5. #25
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,492

    Default

    Quote Originally Posted by yeevveey211 View Post
    ok I'm stumped I really wanna figure this out . it's a loud knocking vibrating my whole truck and does NOT go away after warm up . first thoughts that pops in your guys head ?
    so far all I get is you removed the plugs and put them back in. did you crank engine with plugs removed ? pressure test the fuel system for failure ? compression test ? measure plug wires for resistance to be all about the same .

    when cranking , engine plugs out, remove fuel pump fuse.

    with sound issues it is not easy over the internet to diagnose this .

    piston knock or ?????

    what plugs are in there ? who made them ? do they all have the same color ? how many miles on the plugs ? plugs can crack . if the water got on a hot plug or you dropped it this is possible.

  6. #26

    Default

    Quote Originally Posted by geo1 View Post
    try pulling a spark plug,one at a time,and run it,this way you can isolate to a specific cylinder,otherwise pull off valve covers,look for valvetrain failure
    yes i did that still having the same knocking noise im going to pull valve covers off right now to check inside

    - - - Updated - - -

    Quote Originally Posted by j cat View Post
    so far all I get is you removed the plugs and put them back in. did you crank engine with plugs removed ? pressure test the fuel system for failure ? compression test ? measure plug wires for resistance to be all about the same .

    when cranking , engine plugs out, remove fuel pump fuse.

    with sound issues it is not easy over the internet to diagnose this .

    piston knock or ?????

    what plugs are in there ? who made them ? do they all have the same color ? how many miles on the plugs ? plugs can crack . if the water got on a hot plug or you dropped it this is possible.

    yes removed the plugs they all look good not cracked they all have good spark. did not compression test i could test today. i also am going to pressure test the fuel today.
    i will check the fuel pump fuse today also
    i can try and get you guys a video clip or sound clip
    all the plugs are same color and do not see any signs of carbon build up or burned plug,
    i might as well replace them since i am going to the auto store to get a fuel pressure tester

  7. #27
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    the reasoni think behind running it with one plug removed at a time is by taking pressure off components,youre basically removing the compression stroke to each cylinder,i would think the sound should change quite a bit

    - - - Updated - - -

    add to;you have ruled out a leaking injector,my run test would probably show a bottom end problem,but youre motor is shaking,so more likely top end (skipping)one other easy test is while running,press a long handle screwdriver to youre ear and other end to each injector one at a time and listen for clicking,might be helpful

  8. #28
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    any luck finding anything?

  9. #29

    Default

    Quote Originally Posted by geo1 View Post
    any luck finding anything?
    yes I pulled my Valve cover off and pulled rockers off and found a bent pushrod!!!!!!!!!!
    heres a picture

    - - - Updated - - -

    you think I have a bad lifter?

    - - - Updated - - -

    it stuck valve ? how can I check either ?
    Attached Thumbnails Attached Thumbnails image.jpg  

  10. #30
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,492

    Default

    since you had no issues until a cold start then I would say the cylinder was hydro-locked. If all the rods are good and only one cylinder has the bent rods this would be a good guess.

    with a rod bent the plug should look bad. could be stuck rocker arm but on start up that would be weird with no warning prior to this. bent rod from over reving the engine with your short trip driving I can't see that .

    - - - Updated - - -

    you think the piston come off the crank ?

Similar Threads

  1. Engine Knock Sensor help!
    By 2003-5.3-V8 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 11-30-2011, 03:23 PM
  2. Hot Engine Knock
    By Lil_Red_Chevy in forum GM Powertrain
    Replies: 5
    Last: 06-09-2011, 11:42 PM
  3. Engine Knock - Not Piston Slap
    By fargo_182 in forum GM Powertrain
    Replies: 5
    Last: 05-10-2010, 02:22 PM
  4. '97 silverado engine knock
    By digger4x4 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 12-21-2009, 10:29 PM
  5. 5.3 engine knock
    By treefarmer in forum GM Powertrain
    Replies: 2
    Last: 01-27-2008, 03:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •