GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1
    Jr. Apprentice
    Join Date
    Jun 2012
    Location
    Cincinnati, OH
    Posts
    17

    Default 2000 Chevy Silverado - Late/No shifts & Whiny 4WD

    I'll preface this post by saying that I have still not been able to identify a way to start my own build thread, so as to have all of my truck whoas contained in a succinct package. If there is a way to do this, or I have posted incorrectly, please advise (sorry Mods, #newbie)

    My 2000 Chevy Silverado 5.3L Z71 w/4L60E transmission and approximately 160K miles has started to provide me with some challenges; though no trouble codes are currently being thrown, and there is no check engine light. (Recently through a P0300 - Random Misfire, but I do not think it's related; tell me if you think otherwise).

    The truck will not shift from 1st to 2nd while under heavy load. It shifts very late, and maintains high RPMs regardless of % throttle applied. If I let of the gas a bit around 4-5K RPM, it then shifts in to 2nd gear. This is repeated during highway driving while trying to shift up from a cruising speed. 65 and below, it sits with high RPM; around 3500, 4000 - which is much higher than I remember and is killing my gas mileage.

    The first time this happened, I decided to flush the transmission fluid for the first time, though I did not include the full 11 qts w/torque converter. I was hoping something simple would fix the problem, but I regress. The major thing that made this job a massive PITA was the stupid gear selector bracket on the driver's side of the transmission drain pan (deep). I could not get it out of the way, and getting to the top where the 6 point bolt heads are (of course rusted) was impossible for me. Deep in to the evening with little light and transmission fluid dumping all over me, I ended up letting out a few thunderous man grunts and profane statements to get it out. It was fine to put back on, which puzzled me more. If there is a DIY for this action, please let me know. I also have not found a lot of information with how to also flush the torque converter, and I'd like to know how involved that job is too.

    I spend most of my time in 2WD as well, with very light towing (helping friends move, a motorcycle, etc) but some limited 4WD driving for snow. I am used to hearing a little bit of whine in 4WD especially at low speeds, but have recently thrown a "service 4WD" light a few times. I am hoping that a fluid change here will allow me to move forward.

    I have a bunch of Valvoline extended life DEX/MERC transmission fluid, Lucas Oil 75W-90 transmission/differential fluid, a pump bottle, and a week to get these problems addressed before my spring break is over. I also got a new 1-2 shift solenoid, though I am not sure if I need it.

    I am not about to call it a day, liquidate the truck for $5-6K and take out a big loan on something new. Any help/resources/input you can provide is great appreciated. Please see my other posts for other problems, some of which will be a much more involved job I am sure. For now, I'll have my nose in my Haynes and these forums.

    Thanks

    - - - Updated - - -

    (Sorry for the bump, not attempting to be a self-promotion)

    I just found my older original thread on this topic that I was not able to find:
    http://www.gmtruckclub.com/forum/sho...nge-Gone-Wrong

    To answer those questions:


    1. There were no metal shavings or obvious debris in the transmission pan, it was just dirty.
    2. The filter itself did not look that bad either.
    3. I knocked the cap off of what I believe is the 1-2 transmission solenoid, but put it back on before the pan and it seemed fine. (I bought a new one just in case)
    4. It went back on fine.
    2000 Chevrolet Silverado LS Z71 Ext Cab + Long Box
    2002 Suzuki SV650S
    1992 Eagle Talon TSi

  2. #2
    Jr. Apprentice
    Join Date
    Jun 2012
    Location
    Cincinnati, OH
    Posts
    17

    Default

    May have found the issue.

    Trouble Code: P0751 - Shift Solenoid A Stuck Off

    Will return with results after replacement.
    2000 Chevrolet Silverado LS Z71 Ext Cab + Long Box
    2002 Suzuki SV650S
    1992 Eagle Talon TSi

Similar Threads

  1. 97 Silverado shifts hard when warm
    By Eddie Don in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last Post: 08-31-2011, 03:50 PM
  2. Replies: 12
    Last Post: 04-09-2011, 09:15 AM
  3. New guy; question abt hard shifts with 2010 5.3 6sp Silverado?
    By RMC_SS_LDO in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 6
    Last Post: 01-04-2011, 09:46 AM
  4. High pitched whiny noise
    By jessb_55 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 02-28-2010, 03:36 PM
  5. late 70s chevy truck parts a little of everything here
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 06-14-2009, 02:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •