GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1
    Sr. Apprentice
    Join Date
    Mar 2013
    Location
    Franklin, TN
    Posts
    42

    Default Hum thru L/F speakers w/ headlights on

    My 2010 Silverado 1500 LT has a hum thru the l/f door speaker and tweeter if the headlights or parking lights are on, but not during the daytime in auto mode with DRLs on. Anyone hear of this before or have a clue what could be the cause? The him does not change volume or change frequency with engine RPM. I just bought it and everything appears stock although I did see pics of this truck with blackout taillights that were changed back prior to my purchase.

  2. #2
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,487

    Default

    Quote Originally Posted by Trucking View Post
    My 2010 Silverado 1500 LT has a hum thru the l/f door speaker and tweeter if the headlights or parking lights are on, but not during the daytime in auto mode with DRLs on. Anyone hear of this before or have a clue what could be the cause? The him does not change volume or change frequency with engine RPM. I just bought it and everything appears stock although I did see pics of this truck with blackout taillights that were changed back prior to my purchase.
    swap out the speaker with another . coil could be shorted/burned up.
    since this is only the driverside speaker your radio amplifier may be damaged.a shorted speaker could cause this to occur. also shorted wire to speakers. speaker wires should not touch body ground.

  3. #3
    Sr. Apprentice
    Join Date
    Mar 2013
    Location
    Franklin, TN
    Posts
    42

    Default

    Quote Originally Posted by j cat View Post
    swap out the speaker with another . coil could be shorted/burned up.
    since this is only the driverside speaker your radio amplifier may be damaged.a shorted speaker could cause this to occur. also shorted wire to speakers. speaker wires should not touch body ground.
    Thanks, I forgot to include that the L/F speaker and tweeter work fine aside from this noticeable hum that only occurs with the headlights on.

    - - - Updated - - -

    Also, I need to add here that this hum/buzz occurs whether the radio is on or off.

  4. #4
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,487

    Default

    with the radio off and its hum/buzz then pull the radio out and check the wires for shorts.

  5. #5

    Default

    The 2010 trucks have the speakers on whenever the truck is on (as well as the retained power feature). The radio is only one of the devices that use the speakers. Onstar and the chime alarms also need the speakers, the amps are used by the 3 systems.

    I'm going to suggest that if the previous owner darkened the tails, perhaps he installed HIDs in the front. They may still be there, maybe removed and the transformer was left behind and connected. It sounds to me like a transformer hum.

    If no indication of HIDs in the truck, check the headlights for a bad/dirty ground.

    If that doesn't help, start pulling fuses that are part of the external lighting systems, do it one at a time until the hum stops.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  6. #6
    Sr. Apprentice
    Join Date
    Mar 2013
    Location
    Franklin, TN
    Posts
    42

    Default

    Quote Originally Posted by RayVoy View Post
    The 2010 trucks have the speakers on whenever the truck is on (as well as the retained power feature). The radio is only one of the devices that use the speakers. Onstar and the chime alarms also need the speakers, the amps are used by the 3 systems.

    I'm going to suggest that if the previous owner darkened the tails, perhaps he installed HIDs in the front. They may still be there, maybe removed and the transformer was left behind and connected. It sounds to me like a transformer hum.

    If no indication of HIDs in the truck, check the headlights for a bad/dirty ground.

    If that doesn't help, start pulling fuses that are part of the external lighting systems, do it one at a time until the hum stops.
    Thanks, yes- I have noticed that at night, even after shutting the headlights off, that the hum continues until I open the drivers door, terminating the retained power feature. Interesting. No HIDs installed now and will check for evidence of anything left behind but no apparent evidence at this point. So I'll check the headlamp grounds, then start pulling fuses- there may even be a dirty fuse connection that is increasing amperage to a device utilizing the l/f speakers.
    Good places to start. Thanks kindly.

  7. #7
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,487

    Default

    Quote Originally Posted by Trucking View Post
    Thanks, yes- I have noticed that at night, even after shutting the headlights off, that the hum continues until I open the drivers door, terminating the retained power feature. Interesting. No HIDs installed now and will check for evidence of anything left behind but no apparent evidence at this point. So I'll check the headlamp grounds, then start pulling fuses- there may even be a dirty fuse connection that is increasing amperage to a device utilizing the l/f speakers.
    Good places to start. Thanks kindly.
    a dirty fuse or loose fuse would reduce current to a device not increase. grounding check is a good idea. also as I mentioned checking the speaker wires for a short to ground.

    could be in the amp unit .

    update : sure can be the radio . did some looking and the radio units have these type issues. cooling fan etc.. in the unit.
    Last edited by j cat; 03-20-2013 at 12:42 PM.

  8. #8
    Sr. Apprentice
    Join Date
    Mar 2013
    Location
    Franklin, TN
    Posts
    42

    Default

    Pulling the fuses for any of the lights, the radio, or the amp don't stop the hum. In fact pulling the amp fuse made it louder. Today I pulled the #15 fuse on the dashboard fusepanel for the BCM and the hum stopped. I want to pull the fuses for the several body harnesses on the fusepanel under the dash to see if the hum is localized within one of those circuits, but I can't get the darned fusebox cover to come off, so apparently there's some safety device keeping it on I haven't figured out yet.

Similar Threads

  1. new speakers
    By reggiecab2000 in forum Audio, Video & Gadget Tech
    Replies: 7
    Last: 06-20-2012, 02:44 AM
  2. Best Speakers To Replace Stock Speakers?
    By MentalMike in forum Audio, Video & Gadget Tech
    Replies: 23
    Last: 11-02-2010, 07:20 PM
  3. need help with speakers....
    By DSpivey in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 11-19-2009, 10:05 AM
  4. 4x6 Speakers
    By PearlWhiteGT in forum Audio, Video & Gadget Tech
    Replies: 11
    Last: 08-03-2009, 12:46 PM
  5. speakers
    By Silveradogearhead in forum Audio, Video & Gadget Tech
    Replies: 6
    Last: 02-08-2009, 05:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •