GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 11

Hybrid View

  1. #1

    Default Suburban brake problem. 1987 w/ 454

    I posted earlier but put in the wrong spot. I have 87 suburban with 454. The rear brakes are not working. I went to bleed them and am not getting any fluid from the rear brakes. The pedal is spongy and goes almost to the floor. I am getting fluid to the rear proportioning valve that is attached to the . But the wheel cylinders are dry. I s there another valve somewhere. Is there a way to test the from proportioning valve?

  2. #2

    Default

    Disconnect the rear side of the valve, have someone push the pedal, no fluid equals bad valve.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Took the wheel cylinder off the right rear and pumped the brakes. Got a good stream out of the brake line. got new wheel cylinder and will put it on. Is there a way that the cylinder could be clogged and not bleed.

  4. #4

    Default suburban brake problem

    Took off wheel cylinder and got a good stream from the brake line when brakes pumped. Will replace the wheel cylinder . can the wheel cylinder get clogged and not bleed?

  5. #5

    Default

    Disconnected the rear side of the proportion valve get a weak stream of fluid. With the rear wheel cylinder off I get a stream but it is not strong. petal is mushy. brake light is on I have replaced the master Cylinder and bleed the front brakes. get a little fluid form the rear when bleeding. I used the cap from the new MC and blocked off rear line of the MC and got a full pedal. Here is my question can the proportion valve be bad and let a little pressure out but not enough to activate the brakes or is it one of those parts that either works or does not?

  6. #6

    Default

    Have put on a 2nd master cylinder. The first one was leaking. A right rear wheel cylinder. Getting a little fluid out of the new wheel cylinder. disconnected the rear line to the proportioning valve and got a little bit of flow. I am pulling the proportioning valve. and replacing it as I expect it is partially plugged. I am thinking of putting a used one one as I cannot find anyone in my area who can get a new one.
    Last edited by Davidh; 03-22-2013 at 10:55 AM.

  7. #7

    Default

    Have now put on two master cylinders. The first one was leaking. Replaced the rear wheel cylinders and the proportioning valve. Again tried to bleed them and get just a trick out of the right rear wheel and nothing form the left rear wheel. Uncoupled the rear line form the proportioning valve and get fluid but not a strong stream. Should I be getting a lot of fluid out of the proportioning valve. it seems like no pressure. Do these valve need to be reset? I checked all the lines and not kinks or breaks in the lines.

  8. #8
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    with something that old it mught be wise to just do a full break line replacement, could be filled with gunk or debris
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  9. #9

    Default

    Is changing the lines pretty complicated? I was considering disconnecting the line and blowing them out.

Similar Threads

  1. 1990 K2500 Suburban Brake problem
    By Mike Hill in forum General Chevy & GM Tech Questions
    Replies: 13
    Last Post: 10-17-2012, 01:55 PM
  2. suburban brake light problem
    By snack dude in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 02-10-2012, 01:09 PM
  3. 2001 Suburban brake problem need help to change rear backing plate
    By superbrat in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 10-23-2010, 07:55 PM
  4. New old box Suburban owner. 1987 Silverado Suburban 4x4 1500.
    By PACNWDude in forum Member Introductions
    Replies: 6
    Last Post: 10-13-2010, 03:57 PM
  5. Fuel Delivery Problem with 1987 TBI 5.7l v8
    By Tagerman in forum Performance & Fuel
    Replies: 0
    Last Post: 02-14-2010, 10:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •