GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Hybrid View

  1. #1

    Default Truck misses at all speeds ~ 1998 Chevy

    Have a 1998 1/2 ton with a 5.0 2 wheel drive. Great truck runs well when running properly. Idles great takes off well bu about 20 mph and above it will miss badly. My mechanic though it might be the distributor. I replaced with a new one . It did not make a difference. He stated that the popping sound I heard was a lean pop which could indicate a bad fuel pump. Haven't tried that yet. I was wondering if it might be a emission component that could cause the problem. I plan on using some Seafoam in the vacuum system to clean them out. does any one have an opinion.

  2. #2
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    e.g.r?try disconnecting it from vac.supply,plug vac.supply,test drive

  3. #3

    Default

    I would check the fuel pressure with a gauge. I also wonder if your egr valve is stuck.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  4. #4

    Default

    I had the same exact problem awhile back with my truck, it just turned out that it was a plugged fuel filter. But the first thing I would do is do a fuel pressure test on the system first. Make sure your getting the correct fuel pressure at the fuel rail. Always trouble shoot like this.... Fuel------> Ignition------> Compression...


    Its possible that your ignition coil is worn out and under a load or higher RPMs it can't keep up with the demand. If you were to keep your truck in park or neutral and bring the RPMs up does it start to miss or only under a load?


    If it seems like it's idling normally then my guess is it's probably not a vac leak, that will usually cause a higher idle or it will die out a lot. Make sure that none of your plug wires are burned or bad. Try starting it at night when its dark and pop your hood open and see if you can see any of the wires arching out.

    Also it could just be something as simple as needing a tune up.. Plugs, wires, air and fuel filter, etc...

    Hope this helps a little, good luck!
    1995 C1500 4.3L 2WD. JET TBI Spacer, JET stage 1 chip, 10mm Taylor custom wires, Pulstar Iridium Pulse Plugs.
    260k miles and still going strong...

  5. #5

    Default

    thanks for the reply. I will check all those things. Replacing the fuel pump will be my last resort

  6. #6

    Default

    Replaced the fuel filter and the coil. Improved the missing out somewhat. still doing it. I rented a fuel pressure gauge form the local parts place and it was broken. Waiting for them to get a new one to borrow so that i can check the pressure. The instructions say to test the pressure at the fuel filter. Does anyone have any other way to test?

Similar Threads

  1. Replies: 0
    Last Post: 02-01-2012, 10:40 PM
  2. Chevy Volt misses first-year sales target - CNET
    By GMTC_Admin in forum Chevy Volt Forum
    Replies: 1
    Last Post: 01-05-2012, 11:02 AM
  3. Replies: 0
    Last Post: 01-04-2012, 10:00 AM
  4. Truck smokes at high speeds
    By CarpenterGuy in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 10-17-2010, 01:06 PM
  5. 98 chevy 2500 no blower speeds at all
    By rraber in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 11-22-2009, 10:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •