GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Unhappy p0300 code PLEASE HELP!!!!

    I drive a 2005 silverado 4.3l v6 manual transmission 82,000 miles. a few weeks ago i was geting on the freeway in a bit of a hurry so i was shifting at about 3500- 4000 rpm when I switched into 4th gear at about 60 mph i noticed a significant loss of power and my truck struggled to reach 70 mph ( at half throttle) at a little under 3000 rpm and when i finally reached 70 my check engine light began flashing. i got scared so i let my foot off the gas and went back down to 60 the light flashed for about 10 seconds and turned off on its own i took my truck to a shop to find out why the check engine light came on. they ran a computer diagnostic and it showed "P0300-Random/Multiple Cylinder Misfire Detected" the only other information they could give me was that although i had about 2-4 misfires on cylinders 1,3,4,6 my primary problem was cylinder 5 where i had 676 misfires . i was told to check my spark plugs so last night i changed all the spark plugs,wires, and distributor cap. after i did this i took the truck out for a test run to see if i had fixed the problem so i repeated the scenario that made my check engine light flash the first time and the light began flashing again. Can anyone please help me figure out whats wrong or what else i could check/replace before I take it to a shop and spend tons of dollars in repairs, i hope i gave you guys enough information please let me know anything you think might fix the problem
    2005 Silverado short bed 4.3L V6 with a 5 speed manual transmission a flowmaster muffler and dual exhaust tip and 20" rims

  2. #2
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,484

    Default

    Quote Originally Posted by ricklopez92 View Post
    I drive a 2005 silverado 4.3l v6 manual transmission 82,000 miles. a few weeks ago i was geting on the freeway in a bit of a hurry so i was shifting at about 3500- 4000 rpm when I switched into 4th gear at about 60 mph i noticed a significant loss of power and my truck struggled to reach 70 mph ( at half throttle) at a little under 3000 rpm and when i finally reached 70 my check engine light began flashing. i got scared so i let my foot off the gas and went back down to 60 the light flashed for about 10 seconds and turned off on its own i took my truck to a shop to find out why the check engine light came on. they ran a computer diagnostic and it showed "P0300-Random/Multiple Cylinder Misfire Detected" the only other information they could give me was that although i had about 2-4 misfires on cylinders 1,3,4,6 my primary problem was cylinder 5 where i had 676 misfires . i was told to check my spark plugs so last night i changed all the spark plugs,wires, and distributor cap. after i did this i took the truck out for a test run to see if i had fixed the problem so i repeated the scenario that made my check engine light flash the first time and the light began flashing again. Can anyone please help me figure out whats wrong or what else i could check/replace before I take it to a shop and spend tons of dollars in repairs, i hope i gave you guys enough information please let me know anything you think might fix the problem
    step 1 check fuel pressure for proper pressure using a gage.

  3. #3

    Default

    Rick, check this web page. You may have bad coil pack(s).

    http://www.obd-codes.com/p0300

    Henry
    2004 Chevrolet Silverado 1500; 4x4; Ext. Cab; 5.3L FI

  4. #4

    Default

    Clear the code, add a can of Techron or seafoam to the tank, run it down and see if it returns. I can set a code 0300 anytime I want in my H3 by filling up with cheap city market (same as Kroger) fuel and a can of Techron always cleared it. Needless to say, I no longer use city market fuel. If it continues, all of the above might help.

  5. #5

    Default

    th a lot for the advice guys. the problem turned out to be very simple. about 6 months back i change my distributor cap i bought it from autozone and this last time i checked it i also bought from autozone so what my mechanic found was the because it was a cheap part it wasnt seated how it was supposed to so he put an oem cap on it and the truck has been running perfectly ever since, again thanks a lot for all your advice I really appreciate it

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,484

    Default

    post the part number and the manufacturer . I would also post this on autozone web site with your issues with this part ...this will help others to avoid your failure...

    - - - Updated - - -

    Quote Originally Posted by ricklopez92 View Post
    th a lot for the advice guys. the problem turned out to be very simple. about 6 months back i change my distributor cap i bought it from autozone and this last time i checked it i also bought from autozone so what my mechanic found was the because it was a cheap part it wasnt seated how it was supposed to so he put an oem cap on it and the truck has been running perfectly ever since, again thanks a lot for all your advice I really appreciate it
    your post stated that on march 23 2013 you replaced the distributor cap after you found the p0300 miss fire code... now you say 6 months ago you replaced the cap ...what is the correct story ? did you replace the rotor and cap as a set ? if not this can explain your miss fires .

Similar Threads

  1. trouble code p0300 p0175 p0172
    By raz in forum Chevy Truck Tech Forum
    Replies: 0
    Last: 01-07-2012, 06:35 PM
  2. Code P0200 abd P0300
    By nickpatton_189 in forum Performance & Fuel
    Replies: 1
    Last: 06-30-2010, 11:13 PM
  3. p0300 code?
    By dshewy14 in forum General Chevy & GM Tech Questions
    Replies: 8
    Last: 04-13-2010, 12:02 PM
  4. P0300 Code
    By sociald in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 01-17-2009, 05:07 AM
  5. Code P0300
    By msm1889 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 04-10-2008, 07:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •