GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Hybrid View

  1. #1
    Jr. Apprentice coachg08's Avatar
    Join Date
    Jan 2009
    Location
    Fredericksburg, Texas
    Posts
    23

    Default 2007 Silverado - NO POWER - Help

    2007 NWBS EXT CAB Silverado z-71 4.8L 63k miles

    Ok so this morning i stopped as usual to get my coffee. Came out and went to crank truck and it wouldnt turn over on first try. Did it again and it started up but i noticed my clock on radio went back to 12:00 like the battery had just been reset. Pulled into work, shut truck off, and opened doors -- dome lights did not come on but my radio lights were still on with the door open and key out. I shut the door and attempted to lock with the key fob. Nothing. Opened door and tried hitting the lock button - nothing. Radio lights still on. Put key in the ignition to try and start - nothing but the radio lights went out. I went into work, confused. Came out this afternoon and tried jumping it - nothing. Battery is three months old and was AC DELCO top of the line whatever it was. Before I disconnected both terminals I felt the negative terminal and it was hot. I went under the truck and and disconnected the ground to the frame and cleaned it. Disconnected ground to the engine block and brushed it off and put it back on. Put the positive terminal to the battery back on and then the negative terminal. Horn started going off. Put the key in the ignition and it started -- all electrical was working. I let it run for about 15minutes and shut it off. Went to turn it back on and it was dead. No lights, no chimes, no nothing. Repeated the steps i did earlier to get it to start. Nothing. I checked some fuses and they all looked fine. Pulled some relays but i dont know how to tell if one of them is bad. Could this be a faulty ignition start switch? Any advice or help would be greatly appreciated! I have never come across something like this! Ive never had ANY problems what so ever! The truck has no power and i cant pull any codes. Is there a way to some how get power where i can check a code?
    Jerold - Texas
    2007 Silverado EXT Z-71
    1998 Cadillac Seville STS

  2. #2

    Default

    The battery appears to be "dead". You may need to remove and have it recharged. While your at it, have it tested (it wouldn't be the first new battery to fail after a very short time).

    If the battery post is hot, there is probably resistance. A good clean connection does not heat, a dirty/corroded connection will.

    You may have a failed battery, you might have a bad ground cable, you might have something else. The first thing you need to do is make sure the starting point (battery) is good.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. 2007-2013 OEM Chevy Silverado Power Tow Mirrors
    By parts bot in forum Chevy Parts eBay
    Replies: 0
    Last: 02-10-2013, 11:10 PM
  2. Replies: 0
    Last: 11-14-2012, 05:21 AM
  3. Replies: 0
    Last: 10-16-2012, 04:50 AM
  4. 2007 SIlverado 1500- no power at reverse/aux on 7 pin trailer plug
    By lngtrvlchev in forum GM Electrical Tech
    Replies: 3
    Last: 10-01-2010, 10:46 AM
  5. power programmer 2007 silverado 4.3
    By pdunn77 in forum GM Powertrain
    Replies: 2
    Last: 03-01-2008, 10:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •