GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Question 99 chevy k1500 4x4 ext cab ls-front end issue?????

    If anyone can help I would appreciate it.
    When I am driving and making even a small turn that requires me to hold in that position the steering feels as if it gives and over turns causing me to loose control. Sometimes this even happens when just driving straight then moving steering wheel in either direction to stay in my lane and it just gives and causes my truck to turn very erratical. I just put a pitman arm on but the person helping said that it was up on the shaft as far as it could go leaving about 1 1/2in of the splines exposed, maybe that's the way it goes. this problem started prior to replacing the pitman arm but seems to be worse since new tires, alignment and pitman arm. Anyone have any advice I would appreciate it or I am going to end up in a ditch.
    Thanks,
    Graham
    Thanks in advance,
    Graham

  2. #2

    Default

    98 GMC 4X4 - I have a similar problem, which I believe to have more than one cause.

    The control arm bushings were my first guess, but they look OK.
    I have heard that the steering wheel position sensor (on the steering shaft near your feet) can affect the "gives" feeling. I have disconnected the wires to it for a test. Weirdly, there seems to be some improvement. Is this possible?
    I plan next to check the steering box. Anyone?

  3. #3

    Default

    Check the frame where the steer gear box mounts to the truck as well as all the joints. Are the boots on your end links holding grease? Those are the things I would check first.





    2011 GMC Sierra SLE - 5.3 - 4X4 - Z71 - King Shock Level Kit - Body Color GMC grill emblem - 2 Tone Engine Cover, Rad Cover and Battery Box - Volant CAI - Tru Cool 40K tranny cooler - Sylvania ZXE bulbs Hi/Low -TriFold Hard Tonneau Cover- CoverCraft Seat Covers - Diablo inTune - GoRecon LED under rail lights - GoRecon LED White Lightning Tailgate Light Bar - Windows tinted to 45%- Kenwood DNX6990 - JL Audio C5-650 &650X- JL Audio Amp- Interco Truxus M/T 33x12.50x18

  4. #4
    Jr. Mechanic
    Join Date
    Mar 2013
    Location
    adirondacks,n.y.
    Posts
    113

    Default

    sounds like the pump,youre power assist is not constant,i.e. pressure dropping and rising,giving you that feel.what about a good flushing,fluid is probably dark anyway,cheap place to start and whatever you dont change will be clean

Similar Threads

  1. 96 Chevy K1500 5.7L Rough Start Issue
    By turboleg in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 12-14-2012, 06:43 AM
  2. 1994 Chevy K1500 5.7 Starting Issue
    By LawnServiceGuy in forum Chevy C/K Truck Forum
    Replies: 6
    Last Post: 10-29-2012, 02:17 PM
  3. 95 chevy k1500 4wd issue
    By brentlemaster in forum GM Powertrain
    Replies: 1
    Last Post: 05-16-2011, 03:38 PM
  4. Got an issue with my '92 K1500
    By silverlion in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 04-04-2011, 02:00 PM
  5. 95 k1500 4wd issue
    By cover3 in forum GM Powertrain
    Replies: 18
    Last Post: 10-13-2009, 04:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •