GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3

Threaded View

  1. #1

    Unhappy PO300 code for 2010 Chevy Silverado(again)

    Hello everyone, this is my first post but i have enjoyed reading posts by all of you. I have a problem with my 2010 silverado with the 5.3 AFM and engine code 3 which is the aluminum block. This is the seventh time the truck has been to the dealership with this type of problem. The truck only has 24,000 miles and is taken very good care of. The truck has had spark plugs replaced, valves and lifters replaced, new afm control, oil diverter placed in oil plan and now it is misfiring again. The fix this time is supposed to be to replace the pistons and rings. I almost forgot that both valve covers have been replaced. The truck has sporatic idle and has been this way since the day i drove it off the lot. It also has oil consumption problems. My question is has anyone else had this done and did it fix the problem. I have filed claims with Chevrolet and have been offered nothing except it should be fixed this time. I am to the point where i need my truck fixed or give me a new vehicle and this could be your science experiment to come up with a fix for this problem. Any help would be appreciated. The saddest part is this is my first and probably last Chevy. I have had a Ford and several Toyota's and this truck has been in the shop more than those combined. Not trying to bash, but i need something done. The misfire code is being caused by the dreaded AFM.
    Last edited by kevrev42274; 04-04-2013 at 07:21 PM.

Similar Threads

  1. 1998 Chevy 4x4 w/5.7 w/PO300 Code.
    By metal77 in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 11-02-2011, 07:54 PM
  2. Tahoe PO300 Code
    By Jbugg in forum Chevy Truck Talk & GM News
    Replies: 1
    Last: 07-29-2011, 01:00 PM
  3. PO300 and PO161 and bad MPG 1996 K1500 Chevy
    By Dantheman96 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 05-05-2011, 11:42 AM
  4. Replies: 3
    Last: 12-22-2010, 08:38 AM
  5. info - misfire on a 2001 chevy tahoe 5.3 code PO300
    By x1078p in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-18-2009, 11:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •