GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1

    Default Electrical issues w/Trailer

    have a 2005 1500 4wd but don't have power to the trailer tail lights at the plug I looked at both fuzz boxes I have power on every thing else what am I missing?

  2. #2

    Default

    Welcome to the club, it's great to have you aboard. I am sure someone will be along soon that can help you with this issue. Upload some pics when you can.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  3. #3

    Default No power on trailer plug for running lights.

    I am new, but great site:Any way I have no running lights at my trailer plug I have looked at both fuzz boxes what am I missing?

  4. #4

    Default

    Welcome to the site.

    Add your vehicle info, to narrow down who knows most about your era truck.
    Look for a break or corrosion in the wiring harness from the plug back to the truck. What part of the truck depends on the year and size.

    Good luck,

    1999 Chevy K2500 Suburban 350
    K&N, reworked cai, Thrush cat-backs
    Vinyl, cranks, floor shift, and rear air!

  5. #5
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Welcome to the Club!!

    I moved your thread to the correct section and changed the title to match your topic. This will help you in getting more responses/ideas.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  6. #6

    Default

    Is this a 7-spade plug? If so, check the connection behind the 7-spade outlet. Sometimes it comes loose. If it isn't loose, remove the connection plug and make sure all of the pins are properly seated, as it's easy to bend the pins when replacing the connection cap and that could be the problem. Last, while inspecting/checking this stuff make sure the terminals (both on the connection side and on the 7-spade connector side) are clean and free of corrosion.

  7. #7

    Default

    Good advise @SurrealOne. if that doe not cure the problem, recheck the fuses. I don't have a wiring diagram for the '05, but most of the time the trailer circuits are separately fused so a trailer short does not kill the truck lights.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  8. #8

    Default

    Thanks for the tips ,I did find a 30amp fuse bad but still no luck on a fix the lights on one trailer worked and on the boat it did not, what did Charlie Brown say ahhhhhhhhhhh. But the fuse picture did help and I'll look more tomorrow.

  9. #9

    Default

    Ok, if one trailer works and one does not....the problem is not at the truck.

    The trailer that does not work has a problem with the running lights, check bulbs, wiring and the ground.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  10. #10

    Default

    Update: I found a 30 amp. and a 15 amp. blown because their was a wire touching the travel trailer Thanks all for the help, the fuse pictures did help a lot.

Similar Threads

  1. electrical issues?
    By nitz0422 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 01-06-2012, 10:59 AM
  2. Electrical Issues
    By horsemanmike in forum GM Electrical Tech
    Replies: 3
    Last Post: 07-22-2011, 09:44 AM
  3. Electrical Issues
    By Joethepoolguy in forum GM Electrical Tech
    Replies: 7
    Last Post: 03-21-2010, 09:28 PM
  4. Electrical issues
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 4
    Last Post: 02-05-2010, 09:51 AM
  5. Electrical Issues
    By focal318 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 08-29-2009, 10:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •