GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Question What is wrong with my trans? (4L60E)

    I am having a problem with my trans shifting. It is a 1995 4L60E. I had it rebuilt a few months ago. When I first got it put in it started doing this then it stopped and did fine then it started again this weekend. It will not shift from first to second until around 25 mph. Then it will not shift from second to third until around 50 mph. The only way that I have found to get it to shift into over drive is to get it up to about 80 on the interstate then set the cruise and then hit the back down button and coast down to about 70 and it will usually stay in OD for a few minuets, but it won't stay for long. The guy the rebuilt the trans is telling me it is likely a computer problem, but I have no idea. Has this ever happened to anyone else or does anyone know what is causing this?

    It doesn't do it every time I get in the truck, just most of the time now. I can tell that it is going to do it when I get in and push the break and put the truck in gear, it will lurch like it is under some heavy pressure. When it doesn't do that it will drive fine.

  2. #2

    Default

    Quote Originally Posted by jireh customs View Post
    I can tell that it is going to do it when I get in and push the break and put the truck in gear, it will lurch like it is under some heavy pressure. When it doesn't do that it will drive fine.
    When this happens, are the idle rpms normal, or is engine revving?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    it is revving

  4. #4

    Default

    My 95 did the same Lurch thing also, when that happened it would not shift into first gear, it would always stay in second. Then when it did shift it slammed into the next gear. It only happened if I let it idle for a long time. If I shut it off and let it sit for a minute or two and restarted it, it would run fine. I never figured out what the issue was. I did have the shift solenoids changed under warranty and it fixed it for a while.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  5. #5

    Default

    Quote Originally Posted by jireh customs View Post
    it is revving
    I'm thinking, something is causing the throttle to rev the engine.

    Check around the pedal for a carpet, or a beer can, that might be moving the pedal off idle.

    You need the engine rpms in the "normal" range, or the trans will shift hard.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  6. #6

    Default

    It usually idles at about 800 rpm. When it is doing this it idles at about 1100. There is nothing that would be holding the pedal and that should not affect the shifting into higher gears.

  7. #7

    Default

    Turns out that it was the throttle position sensor. Replaced that and it is driving great.

Similar Threads

  1. Replies: 0
    Last Post: 07-02-2012, 08:34 PM
  2. 4l60e trans problems
    By chevyman94 in forum GM Powertrain
    Replies: 10
    Last Post: 10-17-2011, 01:20 PM
  3. Quick trans question 4l60e
    By JOHNNYBLACKEYE in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 3
    Last Post: 11-14-2009, 02:33 PM
  4. 4L60E trans, 9 or 13 pin connector
    By ashman_42 in forum GM Powertrain
    Replies: 0
    Last Post: 04-26-2009, 12:17 PM
  5. How to 4L60E to 4L80E trans swap
    By RockHead in forum GM Powertrain
    Replies: 1
    Last Post: 10-12-2008, 09:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •