GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 97 GMC Suburban sputters under load

    I have a 1997 GMC Suburban. There's been a problem with acceleration for about 6 months. Basically, truck start fine, no hesitation. Idles fine. Sitting in park and revving up the motor it sounds fine.
    When I'm going low speeds of 20-30 MPH the truck runs fine. but then when I try to accelerate, it sputters and cuts out (never dies) until I release the pedal and then it runs fine again.
    When I start the truck, the fuel pump has gotten louder, and now while its running the whining the fuel pump makes kind of goes up and down in pitch. I have replaced the fuel filter, newer plugs, wires, rotor. I took it to Autozone and hooked it up to the code reader and it says it's running lean on bank 1 and bank 2 (engine light is on). Truck has 168,000 miles.

    I think it might be the fuel pump, but I have also heard it could be the O2 sensors. I can't afford to replace everything right now so I was going to do the fuel pump myself this weekend but wanted to make sure that was the problem. Has anyone heard of this situation before?

    Thanks for any help!!

  2. #2

    Default

    I can't afford to replace everything right now so I was going to do the fuel pump myself this weekend but wanted to make sure that was the problem.
    I was going to suggest a fuel delivery issue. If you don't want to "guess and check" on the fuel pump, borrow the fuel pressure tester kit (I think Autozone lends it out) and see what the fuel system is doing before going to the expense of replacing the pump.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

  3. #3

    Default

    Ok thanks! Do you happen to know what I'm looking for during the test? I've never done one of these before.

  4. #4

    Default

    Any good manual should describe a fuel pressure test. Basically:

    1) before starting the engine you are looking for a pressure of 60-66 psi
    2) A slight drop after starting the engine, but it should not drop below 50-55.
    3) When you rev the engine or otherwise under load, the pressure should remain high (in your case, your symptoms could be caused by the system pressure dropping off under load).
    4) When the engine shuts off, the system should remain pressurized.

  5. #5

    Default

    Quote Originally Posted by MrShorty View Post
    Any good manual should describe a fuel pressure test. Basically:

    1) before starting the engine you are looking for a pressure of 60-66 psi
    2) A slight drop after starting the engine, but it should not drop below 50-55.
    3) When you rev the engine or otherwise under load, the pressure should remain high (in your case, your symptoms could be caused by the system pressure dropping off under load).
    4) When the engine shuts off, the system should remain pressurized.

    Ok, I will check it out, Thanks!

  6. #6

    Default

    Ok, looks like it was the fuel pump. A friend and I dropped the tank yesterday and replaced the fuel pump and no more problems! I didn't get a chance to test the pressure before we replaced it, the auto parts store would only sell me the tester, wouldn't let me borrow it.

    But the pump sounded so bad while it was running we took a chance. It was also missing the filter screen at the bottom of the pump that was installed (looks like it has been replaced before), so when I put in the new pump, I added a filter screen also.

    Didn't take us long either, a fairly simple process. Had it done in a little over an hour. So the pump was $90 and the screen was $7 and a 12 pack for Jim, $10. Well worth it!

    Thanks for the replies back!

Similar Threads

  1. 89 2500 Sub sputters & dies under load - 350 small block
    By bakerderek0 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 10-01-2012, 07:20 AM
  2. LED watt per lumen/ load rating ? Load resistors
    By PantheraUncia in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 07-29-2012, 11:01 AM
  3. '88 Blazer sputters and misses under load
    By flatearthling in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 9
    Last: 08-04-2011, 02:12 AM
  4. 93 Suburban 2500 ticks under load.
    By jeffrey.falkner in forum GM Powertrain
    Replies: 6
    Last: 05-02-2011, 11:38 AM
  5. 1996 Silverado Spits and Sputters under load?!?!?
    By Rbernsdo in forum General Chevy & GM Tech Questions
    Replies: 11
    Last: 10-23-2010, 11:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •