GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Jr. Apprentice
    Join Date
    Jun 2012
    Location
    Cincinnati, OH
    Posts
    17

    Default 2000 Chevy Silverado - Braking Issues "f*ck the rust"

    I'll preface this post by saying that I have still not been able to identify a way to start my own build thread, so as to have all of my truck whoas contained in a succinct package. If there is a way to do this, or I have posted incorrectly, please advise (sorry Mods, #newbie)

    Some brief background. I purchased a 2000 Chevy Silverado Z71 Ext Cab + Long Box with one previous owner and about 109K miles from a dealership in Northeastern Ohio. I've traveled a lot, but most of my upbringing and wrenching took place in Florida, where there is never any snow; and it is the most glorious ever. When I purchased this truck, it was just before winter, and I completed what I would consider to be a fairly thorough inspection. Though I saw some light rust underneath the cab and a few other spots, it didn't seem like a huge deal. That was in 2008.

    3 years later, I went through what I can only describe as an equally terrifying and boneheaded experience. I got busy with school and work, and I started to neglect my truck. Not in the sense that I abused it, but in the sense that it became something to get me from point A to point B. I stopped wrenching, I stopped doing my own Oil changes; I was too busy (or so I told myself). After a while, I started to experience a funny brake pedal press, and decreased stopping responsiveness. This was accompanied with what I would explain as a "Operation" sounding (yes the board game) buzz and resistance to apply pressure, like all accessories or assistance to the brakes had been lost momentarily. At first, i thought pressure, but the fluid level did not change much. Then I thought pads/rotors etc, but a quick check did not leave me overly concerned. I drove the truck for about one more week, and it would only happen every now and then. The ambient temperature did seem to impact the frequency of the occurrence as well, it happened more when it was warmer out. The boneheaded part was continuing to drive it for another week without seeking the help of a mechanic. The terrifying part game by way of me driving downhill in rush hour traffic, in a 5000 lb truck, pressing the brake and feeling it go instantly to the floor; without decelerating the truck whatsoever. I downshifted. I applied the parking brake slowly, which also seemed to do little. After riding the shoulder, scrubbing some speed on a median curb, and jumping out in a non-crowded intersection and fred flinstone'ing my truck in to a snow bed; I sat out of breath on the tailgate waiting for a friend to pick me up feeling fortunate things did not turn out much worse.

    Rust had attacked the factory brake lines just behind the driver's side wheel well under the cab. Eventually, the pressure of the brake fluid ruptured the metal, and while I was driving down the highway, all of the fluid had leaked out without me knowing. The same rust had damaged/weakened my intermediate parking brake cable, which broke when applied. I paid a shop $2000 that I didn't have to replace all factory brake lines, as well as pads and rotors. I new it was a labor intensive job, and it was out of my league; I needed to have my truck back. I told myself it would allow me to keep the truck for a nice long period of time. I did the parking brake cable before the tow truck arrived.

    That was two years ago. Just this weekend, the same thing started to happen. The rust has gotten far worse, though I have not found any leaks in the brake lines again. The exposed portion of my parking brake is rusted, and it does not work as intended either. I have one week to devote some time to this (Spring Break), and I am trying to make sure I exhaust every option before sending it back to the shop. Any help or assistance you can provide is greatly appreciated. I'm not new to wrenching, but the new Water Pump last weekend is the most advanced I've gotten so far on this truck. The long term strategy is going to be to get the truck in the air, start pulling off rusty suspension components, and start either replacing them or covering them with a product like POR-15. It will get warm soon, and I'll be able to ride my motorcycle around while handling this.

    Synopsis/Questions:


    1. When applying the brakes, lack of pedal responsiveness (opposing force) + buzzing noise (ABS module?) + decreased stopping power is caused by = ???
    2. Driving big trucks with no brakes is stupid and dangerous
    3. Rust is the worst ever
    4. Any other things I should be checking?


    Thanks
    Last edited by Fraterado1855; 03-18-2013 at 01:00 PM. Reason: grammar
    2000 Chevrolet Silverado LS Z71 Ext Cab + Long Box
    2002 Suzuki SV650S
    1992 Eagle Talon TSi

  2. #2

    Default

    Quote Originally Posted by Fraterado1855 View Post
    I'll preface this post by saying that I have still not been able to identify a way to start my own build thread, so as to have all of my truck whoas contained in a succinct package. If there is a way to do this, or I have posted incorrectly, please advise (sorry Mods, #newbie)
    I would PM Steve, or one of the MODs and ask how you would do this.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Jr. Apprentice
    Join Date
    Jun 2012
    Location
    Cincinnati, OH
    Posts
    17

    Default

    I wanted to post back in regard to the problem as I now know what has caused it. Hopefully this is not considered self-promotion Mods.

    When applying the brakes, lack of pedal responsiveness (opposing force) + buzzing noise (ABS module?) + decreased stopping power is caused by = ???

    Answer: Bad wheel speed sensor, losing signal. Trouble Code = C0226

    This can happen due to regular wear as well as corrosion/rust (in my case likely).

    Thanks

Similar Threads

  1. 2008 Silverado Braking Issues
    By BlackBowtie in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 12
    Last: 03-21-2013, 02:51 PM
  2. Replies: 0
    Last: 05-09-2012, 08:50 PM
  3. Replies: 0
    Last: 05-02-2012, 04:30 PM
  4. Rust "spects" front bumper
    By Bulb in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last: 09-30-2007, 07:08 PM
  5. Replies: 0
    Last: 07-24-2007, 12:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •