Hey Ya'll

I'll start with a little background. My wife drives a 99 4Runner and it has the known wacky fuel gauge issue, so we think. I found this on another forum:

Electrical EL010-99 99 & 00 4Runner

Vehicle has to be sitting on a level surface with an inclination of +/- 0.5 degrees.

1.With the ignition switch in the Off position, press and hold the trip speedometer reset button.
2. Continue pressing the reset button while turning the ignition switch to the On position.
3. Within 5 seconds of turning the ignition switch On, release the trip switch, press trip switch 3 times and on the 3rd press, hold the switch for 5 seconds. The buzzer will sound for 1 second at 800HZ.
4. After the buzzer stops, release the trip switch.
5.Press the trip switch one more time and hold for 5 seconds. Once more the buzzer will sound for 1 second at 800HZ


So, we tried it and it appears it helped. Gauge seems to not drop off of fuel as fast. Like before you would go 20 miles or so and it would drop to almost to the 3/4 mark.

My real question is this capability available on all vehicles? I drive the 99 NBS Ext-cab Z71 and my guage seems to read weird. Goes forever on full then drops "LIKE A ROCK." get to about 220 miles to a half tank then again drops to a 1/4 after like 40 miles. This truck is fairly new to me so just wanting to find out what is normal and what is not.
I'm sure I'm missing some info but kinda a newbie to asking questions on these forums. Interested to hear what you all think.

Tim