GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 2007 suburban a/c problem

    In my 2007 chevy suburban LT (Weird set of options in it), my driver and passenger air conditioning are not working, but my rear seating air conditioning is working perfectly. What do you think is wrong with the a/c. The chevy dealer wants to charge me out the wazoo too even check it

  2. #2

    Default

    what is not working? does it not blow air out on the pass side or just not cold air?

    Most common problem would be the blend door for the HVAC system in the dash

    2003 Z71 Silverado LS
    Access roll up cover
    Bed Rails
    Billet Grill insert
    Bed Rug
    CB with PA system
    Waiting to be installed
    Two 8in RF HX2 punch( would have 12s but they got stolen)

  3. #3

    Default

    Very little air blows at all. The air in the back is ice cold

    - - - Updated - - -

    Next to no air comes out the front. The back blows hard ice cold

  4. #4

    Default

    the back is run off its own fan and vent system separate from the front but same refrigerant as the front. does it work with the heat on, does the fan work on all speeds(hear the change in sound at all settings). check to see if when you change it from floor to front vents that it changes. My best guess would be a blend door problem

    2003 Z71 Silverado LS
    Access roll up cover
    Bed Rails
    Billet Grill insert
    Bed Rug
    CB with PA system
    Waiting to be installed
    Two 8in RF HX2 punch( would have 12s but they got stolen)

  5. #5

    Default

    As @Z71_guy has stated, the front and rear are separate HVAC units, sharing the common source of heat, or AC.

    Your front problem could be a blend door, but, I can not tell from your description, if the front blower is working. Perhaps the front blower motor is bad, or (most likely) the speed control module is bad.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. 2007 Silverado 5.3 oil problem
    By angrywasp in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 08-27-2012, 03:39 PM
  2. 2007 Suburban Instrument Panel Goes Out / Electical Problem
    By tomtina1 in forum GM Electrical Tech
    Replies: 3
    Last Post: 09-30-2010, 05:19 PM
  3. 2007 avalanche 2wd trans problem
    By phazelwood in forum GM Powertrain
    Replies: 0
    Last Post: 05-10-2010, 09:39 PM
  4. 2007 Suburban alternatorelectrical problem?
    By Adirondacker in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 04-19-2009, 08:26 AM
  5. 2007 Suburban lift problem
    By trojans1981 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 03-16-2009, 10:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •