GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default o2 Sensors and Seafoam

    Ok...

    A question that is probably an age old debate but I think I have found the answer...will Seafoam burn out my o2 sensor?

    So I bought a used 2003 Suburban 5.3l (not a flex fuel) w/ 165k miles on it. Original owner, service records, overall great shape- save for the 165k mile part. I figured I could renew it slowly, doing 1 item per month and 2 years down the road I am at the engine phase. I planned on doing plugs/wires, fix leaking oil pan, reoiling the K&N and that was really all that needed to be done, it still seemed to run great.

    I had heard great things about Seafoam from both reputable 1st person conversations and internet speak, and I also heard the caveats but none of those seemed to have facts to back em up...so in anticipation of changing out the plugs and wires, I put a can of Seafoam in 1/2 tank (+ or - 16 gallons) of gas. I ran that around until it was down to about 1/8th of a tank and then had about a 1/2 can in the garage I ran through the power brake booster. I know it says 1/3 of a can but I tried to kill the engine with a heavy pour the last few ounces and it got away from me.

    Started it up and the standard (A LOT of) white cloud of smoke greeted me. I went a couple stop lights and jumped on the freeway and drove it probably 2 miles before getting off (white smoke gone at mile 1). I have to say that post-Seafoam, I did notice a bit smoother idling and accelerating. I drove it for another 20 miles or so thinking Seafoam IS tune up in a can. At that point I thought SUCCESS and went home and proceeded to clean the engine bay for the plug/wire change. I covered the alternator, hit it with the degreaser and hosed it down. I dried what I could, AutoGlymed the engine bay and it got parked it for a day or two. Got in to go somewhere, started it up and POOF!! A big cloud of smoke from under the hood!

    I popped the hood and a greyish smoke was coming from under the drivers side exhaust manifold, it went away pretty quick so I thought it may be just some dressing/degreaser burning off and had no issue with how it was running, until I got in.

    I noticed that my mileage in the DIC was dropping .1 every 10 sec or so when it was idling (I keep it on the mileage thingie for the most part). I took it out and it seemed to run fine, except the horrible mileage. No check engine light and I thought one of the plug wire wasn't firing or something (they looked old). I changed out the plugs/wire yesterday and it made a world of difference in throttle response and power (the old plugs were VERY beat up Bosch dbl plats) but mileage still and issue. There also seems to be a rich smell coming from the drivers side of the engine bay.

    I am waiting on an OBDII scanner to show up in the mail but, long story short, after a bit of research it appears as though a bad o2 sensor would do exactly what I am experiencing. Runs fine, except mileage and no CEL light. That coupled with the fact I Seafoamed the engine, it has 180k miles on it now and smoke started coming from the exact location of the sensor would lead me to believe I would be about a 90% I need to replace the sensor without waiting for the reader? Thanks in advance for any help!

  2. #2

    Default

    Ok...

    A long time ago my uncle told me, after I pulled the rotor cap, rotor and ALL the wires off a car to tune it up, do one thing at a time so you know what you need to go back to if something goes wrong. That's what I tried to do but modified the rule a bit given ECM relearning curve.

    The o2 sensors showed up before my OBDII reader so I replaced them (they looked nasty to me, the spark plugs I pulled look the same). Still wasn't getting the old mileage but I figured the ECM needed to reprogram, I drove around probably 20 miles, with a couple quick freeway jaunts and the mileage was getting better, but still at idle was dropping .1 mile every 30 sec.

    Click image for larger version. 

Name:	photo.jpg 
Views:	77 
Size:	81.6 KB 
ID:	52629

    Considering the ECM was going to have to relearn the air/fuel mix anyways at this point, I decided to do 2 more things- clean the MAF and clean the throttle body. I probably over oiled the K&N anyways I figured. On my return trip to take the o2 loaner socket back to Orielly's I picked up those CRC cleaners and headed home. Took all of an hour to remove the MAF and throttle body, clean em up and pop em back in. Started right up and the idle was a bit high (1100-1200) at first and then drove it for probably another 20 miles with a couple quick freeway jaunts.

    By the time I got home, idle was smooth as silk at 550 rpm, throttle response was crisp, acceleration was much better and the shift points seemed like they were more "correct." It now runs better than my wife's Infiniti! And the MPG that set me on this quest in the beginning... before I was getting about 11 MPG around town and 17ish on the freeway. It is now at 14 MPG around town and 19ish on the freeway. The only thing I need to do at this point is change the fuel filter.

    So with my current experience, my theory is this. I'm probably preaching to an entire congregation at this point but I think GM did a great job of making their ECM's real world friendly in that if the air/fuel system is not perfect, it's not going to throw codes, CEL, etc. The ECM is going to make its adjustments here and there and keep your vehicle on the road with limited trips to a mechanic. It's like an air cooled VW, it'll just keep running, maybe not great but it'll keep running.

    HOWEVER, if you want optimal results, on these vehicles the air/fuel ratios are CRITICAL. Keep the MAF and throttle body clean, keep the injectors cleaned/maintained, make sure your plugs are the irdium that are now the spec, change your wires at the recommended interval and do indeed change the o2 sensors if your vehicle is over 100k in mileage. I'm also gonna say that Seafoam is a great product that worked for me.

    All in all I put in new plugs ($36), wires ($23), o2 sensors- both upstream ($55) - all Denso, 2 cans of Seafoam ($16) MAF cleaner ($8) and TBI cleaner ($5)...total about $150. Not even taking into account the benefit just having done a major service, if I gained 2 MPG, with gas at $4 per gallon, my payback is around .30 per mile. So I would be paid back after driving around 500 miles..or roughly a tank of gas....

    So to recap, Seafoam in the tank at the recommended 1oz per gal, when that runs down do a Seafoam treatment through the brake booster at 1/3 can, change plugs/wires, upstream o2 sensors, clean MAF and throttle body, drive around for an ECM relearn...

  3. #3
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    bump...

    Sorry for the delay in your post being visible. It got hung up in our anti-spam tool.


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  4. #4

    Default

    Excellent advice.

    I'll add to it that some people think you can 'clean' O2 sensors. You can't. Using gas or carb cleaner you CAN clean the carbon build-up from the sensor's louvered cover, but you don't actually clean the sensor, itself. Moreover, even if you could clean the sensor, itself, there's no guarantee that doing so would restore the sensor to its like-new condition and, therefore, readings. The only sure way to do that is to replace the sensor with a new one...

  5. #5

    Default

    To tack on some to what Surreal posted the sensor can be cleaned and carbon removed but the sensor wire itself has been degraded and without repairing the degradation, which as far as I know is not possible short of replacing the sensor, you'll never get test readings or actual readings back to where they started.
    You can make it read better than when it was dirty but thats not the same.

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,357

    Default

    Very good info Now that I am getting close to 100K..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

Similar Threads

  1. Replies: 0
    Last: 02-07-2013, 06:50 AM
  2. Replies: 0
    Last: 01-12-2013, 11:10 AM
  3. oxygen sensors?? what sensors will work on what truck?
    By senorbob999 in forum GM Powertrain
    Replies: 0
    Last: 01-22-2011, 11:17 AM
  4. Seafoam
    By Bobby1021 in forum Performance & Fuel
    Replies: 27
    Last: 05-04-2010, 05:26 PM
  5. seafoam
    By sharpshooterusmc in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 04-01-2010, 05:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •