GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Default Flooded 2010 Silverado! Need opinions

    Hey there. Im new to this site and have seen lots of helpful info so far. Anyways, I bought a flooded 2010 Silverado with 24000 miles on it. It runs and drives, and did when I bought it. Water wasnt too high, but had to replace the wiring harness in the cab and also re-pin some corroded off wires that came off the dash wiring harness. Replaced the main block that the harnesses go into under the dash, replaced the seats and wire harnesses to the doors. Drained and services all the fluids. Now I cannot get the lights on the dash to come off. Check engine light, service 4 wheel drive, abs light, airbag light, Speedo doesnt work, temperature control blows hot on drivers side even when ac is on, but blows normal on passenger side. My buddy owns a shop and hooked up to his scan tool , he checked the lights and codes and couldnt get them to turn off. And for some reason his tool couldnt even read the vin of the truck. I have a good amount invested in this and am at a standstill now, I dont know what to do or where to start.

  2. #2
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,319

    Default

    there could be so much wrong that is not seen.. Where to start.. Where did it come from? The NE area?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  3. #3

    Default

    Yes...the truck is from NY. the damaged wiring i replaced. Everything is working as it should...except the tranny.(as mentioned before). I have heard there is some "learning" a truck can do . Also I know I knew getting into this i would have to replace some modules along the way, but which ones? Nothing above the brake pedal got wet...as I can see the water line

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,319

    Default

    has the trans been opened and looked at? Where are you?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  5. #5

    Default

    I live in Wisconsin. The transmission pan was dropped and flushed 4 times . As the tranny had water in it as did the front diff. and transfer case. Tranny fluid is now bright red as supposed to be and I will drop it again after a few miles .

    - - - Updated - - -

    I replaced the body control module , but didnt replace the air bag module that is under the the center console. It has weather pack connectors and showed no corrosion or evidence of water , but could water get in the module itself then?

  6. #6
    Jr. Mechanic
    Join Date
    Apr 2009
    Location
    North Dakota
    Posts
    130

    Default

    I drowned a pickup with only 4800 miles on it long ago and thank God they totaled it out.
    2013 Escape Titanium 4WD

  7. #7
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,317

    Default

    Quote Originally Posted by Gloomis View Post
    I live in Wisconsin. The transmission pan was dropped and flushed 4 times . As the tranny had water in it as did the front diff. and transfer case. Tranny fluid is now bright red as supposed to be and I will drop it again after a few miles .

    - - - Updated - - -

    I replaced the body control module , but didnt replace the air bag module that is under the the center console. It has weather pack connectors and showed no corrosion or evidence of water , but could water get in the module itself then?
    now the real story is known about this vehicle . your problem is not water. see when a vehicle in in a flood because sea water drowned the vehicle it is R.I.P. ... forget about fixing it period.

    YOU living in wisconsin , I can believe a person from a region with no salt water would by such a vehicle.

    What you have is a salt corrosive problem that will soon eat every sq in of the metals/wiring bearings ///everything metal... saw a program about those vehicles and how they were to be scraped...but you always get the scammers to rip people off like you in the middle of the country not knowing the effects of sea water on a vehicle.

  8. #8

    Default

    Quote Originally Posted by j cat View Post
    What you have is a salt corrosive problem that will soon eat every sq in of the metals/wiring bearings ///everything metal... saw a program about those vehicles and how they were to be scraped...but you always get the scammers to rip people off like you in the middle of the country not knowing the effects of sea water on a vehicle.
    Well, you've ruined his day , yes, salt can destroy metal, but it is usually a factor of how long the metal was exposed to wet salt. Lot's of vehicles are driven into salt sea water to launch boats and to just have fun on a beach. If the salt gets washed off, the tuck is fine.

    Hot electrical wiring does not like water and it can not tolerate sea water. You can not completely remove the damage from charged bare wire and wet salt. The wiring must be replaced. Also, keep in mind, that a component does not need to have been wet to be destroyed. A short somewhere else could have destroyed a dry component.

    Any modules that were exposed must be replaced.
    Any switches that were exposed must be replaced.
    And, of course, any exposed wiring, and connectors, must be replaced.

    Very, very, very expensive and no way reliable.

    From your description, I suspect a problem with the PCM. perhaps a re-flash might work, or a replacement PCM.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,317

    Default

    Quote Originally Posted by RayVoy View Post
    Well, you've ruined his day , yes, salt can destroy metal, but it is usually a factor of how long the metal was exposed to wet salt. Lot's of vehicles are driven into salt sea water to launch boats and to just have fun on a beach. If the salt gets washed off, the tuck is fine.

    Hot electrical wiring does not like water and it can not tolerate sea water. You can not completely remove the damage from charged bare wire and wet salt. The wiring must be replaced. Also, keep in mind, that a component does not need to have been wet to be destroyed. A short somewhere else could have destroyed a dry component.

    Any modules that were exposed must be replaced.
    Any switches that were exposed must be replaced.
    And, of course, any exposed wiring, and connectors, must be replaced.

    Very, very, very expensive and no way reliable.

    From your description, I suspect a problem with the PCM. perhaps a re-flash might work, or a replacement PCM.
    remember that some people were stuck in their homes for a week before they got to get out. the vehicles sat for weeks before being processed by the insurance companies.

    I feel bad for this guy for sure ,,,, he is not the only victim.

    this was an ocean surge not some river over flowing its banks like you get out his way. big difference ..

  10. #10

    Default

    Quote Originally Posted by j cat View Post
    remember that some people were stuck in their homes for a week before they got to get out. the vehicles sat for weeks before being processed by the insurance companies.

    I feel bad for this guy for sure ,,,, he is not the only victim.

    this was an ocean surge not some river over flowing its banks like you get out his way. big difference ..
    Probably Sandy, probably the truck was written off. He may very well have underestimated the damage and the chances of fixing.

    Chances are, the truck is being repaired to be resold....and that is where the real pain will begin, that owner may not know the complete history
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Page 1 of 2 12 LastLast

Similar Threads

  1. Flooded?
    By dfhollums in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 01-07-2013, 04:55 PM
  2. Opinions needed on new sound system in a 2010 Silverado crew cab!!!
    By tyschneid in forum Audio, Video & Gadget Tech
    Replies: 2
    Last Post: 03-31-2011, 09:41 PM
  3. 2010 Silverado Ext. Cab - Audio Install Opinions Needed!
    By bbolton13 in forum Audio, Video & Gadget Tech
    Replies: 10
    Last Post: 04-30-2010, 09:31 PM
  4. Flooded engine with gas
    By philosofy1 in forum GM Powertrain
    Replies: 12
    Last Post: 07-26-2009, 12:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •