GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Default Cooling fan motor relay burning out! (88 Chevy)

    I own a 1988 Chevy Suburban, 2wd r10.
    every time I turn the key, after about 15 seconds it burns out the cooling fan motor relay. This part right here:
    http://shop.advanceautoparts.com/buy...05-relays.html
    After this relay burns out, there are no lights in the dashboard. no ignition, no click, no power. Also, it drains the battery. if I try to jumpstart it afterwards, I get an explosion of sparks when I hook up the alligator clamps to the terminal. Not fun.
    Here is a list of what I've tried so far:
    unplugged the blower motor
    ripped open the harness and dashboard, sifted through piles of multi-colored spaghetti, found nothing. (so far. more suggestions in this department are welcome)
    checked every fuse, none are blown. which makes no sense. why does it burn out the relay instead of a fuse or in-line fuse?
    I haven't recieved much help in the way of wiring diagrams, all of the ones I've found are really simple or partial and don't go very far in depth.
    Any help at all, or gut feelings, or comments are greatly appreciated! this thing's been out of commission for a month and a half. The damn thing doesn't even have an electric cooling fan. (or did it? maybe someone before me modded it.. I think it has a thermal clutch on the fan)

  2. #2
    Jr. Mechanic
    Join Date
    Apr 2013
    Location
    East Central Iowa
    Posts
    88

    Default

    Couple questions. When the battery is hooked up key off,does the battery drain by itself? Did this problem just show up or start after another type of repair?

  3. #3

    Default

    Yeah, it drains when the key is off and the battery is connected too. As to whether this problem showed up after another type of repair, The previous owners did a lot of fiddling and improvising to get the a/c to work. It only caused my battery voltmeter in the dashboard to act up, and I THINK it powers that relay.
    I also did some unrelated engine maintenance before this problem. it only involved disconnecting and reconnecting the wiring harness from the motor.

  4. #4
    Jr. Mechanic
    Join Date
    Apr 2013
    Location
    East Central Iowa
    Posts
    88

    Default

    Ok,been rolling your symptoms around in my melon. It really sounds like you have a small direct short,maybe some where under the hood. Check the heavy red wires that run from the battery,starter and along the fire wall. Just to see if something rubbed together or got spliced into that shouldn't have(I have seen that). Other than that I'd have to have it in my grasp to look at it. Oh, and check the 12 volt wire to the alternator for the same thing. Hope I've givin you some direction.

Similar Threads

  1. Replies: 6
    Last: 04-07-2012, 06:40 PM
  2. actuator stuck on heat/ Air not cooling on 2007 Chevy Silverado
    By heathaa0 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 08-21-2010, 04:39 PM
  3. Burning of the Oil
    By 22inSilverado in forum GM Powertrain
    Replies: 7
    Last: 06-23-2009, 11:31 PM
  4. chevy dealership blows up - Fire Burning at J.K. Chevrolet Car Dealership
    By brian704 in forum The Coffee Shop ~ Chit Chat
    Replies: 4
    Last: 12-15-2008, 07:03 AM
  5. 04 Chevy Tahoe Liftgate Fuse/Relay
    By sindawg10 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 0
    Last: 01-26-2007, 01:34 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •