GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 1996 overhead (rear control) fan switch quit working???

    The overhead fan switch that controls the rear fan blower has quit working. Nothing blows in the rear on any of the settings - dead. I guess the 3 options are fuse, resistor, or blower motor. Anybody have any idea which one? There's lots of info. on the web about the front resistor which is located under the dash, but nothing on replacing the rear resistor. I assume it's located in the back with the motor? Thanks for any thoughts!

    - - - Updated - - -

    I guess I should add that I'm talking about the switch on the front overhead console, not the back switch above the 2nd row seat.

  2. #2

    Default

    I would start by checking the fuse, It should be in the panel on the drive side of the dash. Then, I would use a test light and see if you are getting power to and from the switch, check every position. Next, I would check the power at the fan, make sure it is getting to it. If not then I would track down the resistor which I would also assume is in the rear near the fan. I know that my 1995 silverado had issues with the connector for the front fan melting. Maybe it is something simple like that.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  3. #3

    Default

    Thanks Pikey. I need to do some checking this weekend.

  4. #4

    Default

    Follow up question...some quick checking revealed that the fuse labeled "blower" in the fuse box in the engine compartment was actually missing. I just purchased the vehicle, so I have no idea why they took it out. Anyway, I borrowed a 60 amp fuse from another slot, and the fan controls all work. There's some 50 amp and some 60 amp fuses in that line, so can someone who owns a '96 or similar suburban please look and tell me what amp fuse I need? I think it's the 6th one down from the top in the far right side column of fuses in the engine compartment fuse box. I bought a 60, but figured I would check first to see if someone could tell me what it's supposed to be. The owners manual labels it, but doesn't give amperage. Thanks!

  5. #5

    Default

    I'm not an electrician - is it okay to use a 60 amp fuse in a 50 amp slot?

  6. #6

    Default

    Quote Originally Posted by estrom View Post
    I'm not an electrician - is it okay to use a 60 amp fuse in a 50 amp slot?
    Temporarily if it is absolutely necessary yes, but you won't be protecting the circuit safely.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

Similar Threads

  1. 2001 Suburban Gas Gauge, 4x4 switch and rear wipers not working
    By MrEarp in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 08-24-2012, 11:32 AM
  2. Left Rear Door Latch Just Quit Working
    By bimmer84 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 03-16-2012, 08:12 PM
  3. XM Radio Quit Working
    By kevindsingleton in forum Audio, Video & Gadget Tech
    Replies: 16
    Last Post: 01-02-2012, 01:34 PM
  4. Replies: 3
    Last Post: 12-12-2011, 07:43 PM
  5. Gauges quit working...?
    By offroadaddict in forum GM Electrical Tech
    Replies: 21
    Last Post: 08-25-2011, 08:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •