GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Hybrid View

  1. #1
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default how to clear computer codes ?

    guys, i have a 1990 k1500 with 5.7 v-8.
    to clear all check engine light codes, is it enough to just remove the positive battery cable for a few minutes, then reconnect ?
    i just ready online someone suggest pulling both battery cables, then turning on the inside interior light, to discharge all stored power, then reconnect.
    is all the really necessary ?
    thanks guys

  2. #2

    Default

    Quote Originally Posted by RATRODKING View Post
    guys, i have a 1990 k1500 with 5.7 v-8.
    to clear all check engine light codes, is it enough to just remove the positive battery cable for a few minutes, then reconnect ?
    i just ready online someone suggest pulling both battery cables, then turning on the inside interior light, to discharge all stored power, then reconnect.
    is all the really necessary ?
    thanks guys
    do you already know the cause of the codes?
    Charles 02 z71 Cladded Avy
    Mods: eBay k&n Intake, highflow magnaflow cats & y pipe, 6" FabTech lift, 35" Pro Comps, Superchips #2715, SnugTop, 4.56's, MOOG front end
    Wishes: LQ4 + a beefed up 4L60E

  3. #3
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by kinson33 View Post
    do you already know the cause of the codes?
    yes, it was a 42 code, ignition module or ecm... i changed the module and although it wasnt flashing the check engine light, when i would do the jumper wire it would still flash the 42 code.

    i bought a manual and it said to pull the IGN fuse from the fuse block.. i did that, and the code is no longer there.... so i got it cleared, thanks.

    me changing the ignition module cured the initial problem of it running a little rough from time to time, and major bucking last sunday morning, but three times this week it has stalled on me, either when putting it in gear from a dead stop, or once setting at a traffic light.... its driving me crazy. but i now have the code cleared and can now see if it comes back.

    i wonder if me not having cleared the code initially would have had the irratic effect even though i put the new module in ? i doubt it... gonna see what happens in the next week or so.
    thanks again

  4. #4

    Default

    Quote Originally Posted by RATRODKING View Post
    yes, it was a 42 code, ignition module or ecm... i changed the module and although it wasnt flashing the check engine light, when i would do the jumper wire it would still flash the 42 code.

    i bought a manual and it said to pull the IGN fuse from the fuse block.. i did that, and the code is no longer there.... so i got it cleared, thanks.

    me changing the ignition module cured the initial problem of it running a little rough from time to time, and major bucking last sunday morning, but three times this week it has stalled on me, either when putting it in gear from a dead stop, or once setting at a traffic light.... its driving me crazy. but i now have the code cleared and can now see if it comes back.

    i wonder if me not having cleared the code initially would have had the irratic effect even though i put the new module in ? i doubt it... gonna see what happens in the next week or so.
    thanks again
    Cant imagine not clearing the codes before you fixed it would cause that. Hope it smoothes out, let us know how it goes

  5. #5

    Default

    You said something about the check engine light flashing? That is a class A misfire.. Could do some damage there.. Also, clearing the code does not solve any problem.. Codes and the MIL are set when there is a problem that needs to be addressed, most often something wrong with the emissions system.. Obviously if you were having issues after you changed the ignition module, that wasnt the only existing problem... The next time a code is set take it seriously and know that disconnecting the battery or pulling a fuse only turns off the light and doesnt fix anything..

  6. #6

    Default

    Quote Originally Posted by PhillipL View Post
    You said something about the check engine light flashing? That is a class A misfire.




    Quote Originally Posted by RATRODKING View Post
    ... and although it wasnt flashing the check engine light, when i would do the jumper wire it would still flash the 42 code.
    Doesnt sound like a misfire

  7. #7
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    thanks for the input guys...much appreciated...
    the check engine light last sunday was constantly on, sorry for the mistake.. it wasnt flashing..

    so far, since i have cleared the code yesterday it has not come back on and is running fine...

    thinking back, this is the third ICM i have installed on the truck, and looking in ym manual, code 42 says ignition module or ECM.

    so..... if i get that code again, i will replace the ECM thats under the dash board.... in doing so i have learned that i will have to pull my vehicle specific PROM chip so it knows my vehicle specifics...

    man, i miss the older trucks that i could diagnose just by listening to it...
    the truck runs so darn good for 23 years old, and only having 161k miles... i would hate to get rid of it at this point, but i cant be keep being let down by its erratic stalling...
    i will let you know what happens in the coming weeks... hope it just stays running good.
    again, thanks for your input.

  8. #8

    Default

    Quote Originally Posted by RATRODKING View Post
    thanks for the input guys...much appreciated...
    the check engine light last sunday was constantly on, sorry for the mistake.. it wasnt flashing.

    man, i miss the older trucks that i could diagnose just by listening to it...
    the truck runs so darn good for 23 years old, and only having 161k miles...
    Could always pick up an old model and rebuild haha

    Sorry couldn't be of more use. Hopefully there is a tech checking around that could chime in. Hope it works out
    Last edited by kinson33; 05-20-2013 at 01:00 PM.

Similar Threads

  1. Computer gurus: need help with iPod and my new computer.
    By Jimmeh in forum The Coffee Shop ~ Chit Chat
    Replies: 9
    Last: 04-01-2012, 03:02 PM
  2. Tire Rack Coupon Codes and discount codes
    By ChevyFan in forum Tire Rack
    Replies: 0
    Last: 12-03-2011, 11:42 PM
  3. Do we need to Clear Codes on a Transfer Case and Actuator?
    By derickheggie in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 02-05-2011, 04:20 PM
  4. Why won't my SCT X3 scanner read/clear codes on my `97 Suburban?
    By idowa in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-27-2010, 11:43 AM
  5. How do you check/clear ABS codes?
    By Demick in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 02-27-2010, 11:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •