GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Angry 3rd light not working

    Well title says it all. No back up or brake come on. I do not have a manual so cant figure out if it is on it's own fuse or not. Worked two days ago?? any help?anyone?

    - - - Updated - - -

    ok, all lights are good but there is some moisture in there witch I have never seen before.

    - - - Updated - - -

    found fuse it was CHMSL 15amp, BUT IT WAS GOOD????????
    Tim Walters (Curky)

    Wrangler AT/S 265/70R17 - Trail-FX window vents - Husky fitted splash guards - Silver Star zXe - Leveling kit -

  2. #2

    Default

    First, is the plug connected securely? The third brake light is fed by a harness and there's a removable plug. I'd check that connection. I'd also check the contacts of that connection. Because there is no backup or brake lights (and possibly no cargo lights), I'm guessing the source of the problem is the ground to the 3rd brake light -- as I believe they share a ground wire. Hence why I'd check that connection and focus on it, first.

    If you think moisture is the cause then check the contacts for corrosion -- even a mild amount of it. If present, some contact cleaner may resolve the issue -- and if it does you can follow-up with dielectric grease to help prevent the problem ... but you'll need to resolve the moisture issue, too.

    If it's not an issue at the plug check the contact points where the grounds are shared, too, as well as where the bulbs plug into their sockets.

    If it's none of those things, then I think it's time to trace the 3rd brake light wiring looking for issues.

  3. #3

    Default

    Thank you. I took a 10 min break (at work) and took it off. The soft rubber seal is crack on drivers side. That is where the moisture is coming from and I am trying to find one online. nothing is rusted inside and harness is connected, wires seem tight. I cleaned the inside of the cab sat. Is there a ground or harness under the back seat or between bed and cab?
    Tim Walters (Curky)

    Wrangler AT/S 265/70R17 - Trail-FX window vents - Husky fitted splash guards - Silver Star zXe - Leveling kit -

  4. #4

    Default

    I'm not sure where the ground is, especially in your NNBS truck.

    In my NBS truck the wiring that feeds the 3rd brake assembley comes up the driver's side A-pillar, runs along the edge to just past the driver's side rear door, and then heads toward the 3rd brake light. (i.e. All the wiring under the headliner is fed up the driver's side A-pillar except for the XM antenna wire, which comes up the passenger side A-pillar and then under the headliner near the windshield.)

    I've never traced the wiring past that point, so I'm not sure where it's grounded. A sure-fire way for you to confirm that it is, indeed, the ground, is for you to make your own temporary one (or use a test light, etc.) and connect it directly to the ground on the plug ... then see if things work. (Just confirm your temp ground wire is good using some other location, first, so that you KNOW your temp ground is good before trying it on a circuit you think is bad ... otherwise you're not sure if it's your wire or the suspect circuit. A test light is ideal for this.)

  5. #5

    Default

    Thanks for all the help @SurrealOne let me through one more at you. I found out they do not sell the 3rd light gasket. You have to buy the whole 3rd light. Plummer putty or some kind of silicone to fix it? or get some soft rubber and make my own?
    Tim Walters (Curky)

    Wrangler AT/S 265/70R17 - Trail-FX window vents - Husky fitted splash guards - Silver Star zXe - Leveling kit -

  6. #6

    Default

    If it were me I'd use permatex silicon adhesive. It's sold in black or clear, so take your pick. Thoroughly clean and degrease the existing assembly and seal as well as the surface to which it'll mount, then apply it prior to mating the two surfaces. (If it were me and I were using clear, I'd also run a bead around the outside on all sides of the assembly once it was screwed into place -- think bathroom caulk and you have the right idea.)

    Just keep in mind that if you need to remove the 3rd brake light, again, you'll need a razor blade to remove the soft/ flexible silicon material (cut through it), and you'll need to then remove all the old permatex before resealing it as described, above. Thus, you need to fix your issue before sealing up the assembly.

Similar Threads

  1. Dome Light Not Working in Chevy 2003
    By benjammin365 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 03-27-2013, 05:48 PM
  2. Third Brake Light and Cargo light not working
    By aka510 in forum GM Electrical Tech
    Replies: 3
    Last Post: 11-21-2012, 07:08 PM
  3. Dome light and cargo light not working
    By Randy0702 in forum Chevy Truck Tech Forum
    Replies: 6
    Last Post: 01-26-2011, 08:36 PM
  4. brake light isn't working
    By CarpenterGuy in forum Audio, Video & Gadget Tech
    Replies: 6
    Last Post: 11-02-2008, 09:23 PM
  5. Fog Light Not Working
    By mrbobm in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 11-18-2006, 10:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •