GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default stalls in summer

    Hi all, new guy here and I have a very frustrating problem. My 2004 Sierra with the 4.8L runs great unless the outside temps are 100+ degrees, it will run for 30-45 minutes then will stall, I can feather the throttle and keep it running enough to pull to the side of the road. I will then sit for a minute or 2 and it will start but will only go a half mile before it does it again. This has happened the last couple summers when temps exceed 100. I live in AZ so 100 degrees is pretty common. It doesn't matter how much fuel is in the tank and the air filter is good. Anybody ever have the same experience, any ideas?

  2. #2

    Default

    The problem sounds like vapor lock, but vapor lock is almost unheard of with fuel injection systems sooo.
    Have you ever had the codes read after this happens to see if its leaving a clue?
    If I was gonna troubleshoot this I'd do the following next time it happens:
    Retrieve any stored codes, maybe its a sensor getting a faulty reading and shutting the truck down to prevent damage.
    Check fuel pressure, see if the fuel line has liquid or vapor in it.
    The next step depends on your findings.

  3. #3

    Default

    How do I check error codes? Nothing comes on the dash.

  4. #4

    Default

    2004 should have obd, a code reader.

  5. #5

    Default

    Pack a inline spark tester and a small straight pick in the truck. Next time it stalls cycle the key and see if there is fuel at the test port on the intake, then pop the spark tester on and tell us what you find. With that kind of heat it can be alot of things but sounds like fuel from your description.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    Quote Originally Posted by warrior View Post
    Hi all, new guy here and I have a very frustrating problem. My 2004 Sierra with the 4.8L runs great unless the outside temps are 100+ degrees, it will run for 30-45 minutes then will stall, I can feather the throttle and keep it running enough to pull to the side of the road. I will then sit for a minute or 2 and it will start but will only go a half mile before it does it again. This has happened the last couple summers when temps exceed 100. I live in AZ so 100 degrees is pretty common. It doesn't matter how much fuel is in the tank and the air filter is good. Anybody ever have the same experience, any ideas?

    what I would start with is the fuel pressure test. this checks the fuel pump and the fuel regulator/ injectors for proper operation.

    since your in the hot zone never run on a low fuel condition as this causes the fuel pump to run hot.

    I would also clean the MAF and the throttle body. using MAF cleaner and throttle body cleaner. being a 2004 replacing the ECT and checking its connector is good preventive maintenance since this does go bad after 10 years.

    the other possible cause would be the crank sensor. this when it heats up has been reported to act up. it is under the starter motor.

    no DTC would usually mean a fuel problem. I take it this engine stalls going down the road , not just at idle .

  7. #7

    Default

    mine did the same thing today coming in from work,,,, about 90 to 92 degrees outside and after about a 45 minute drive climbing a hill it went to sputtering and skipping,,, i nursed it home and it went dead in the drive going back to my shop,,, i restarted it which it acted like it didn't want too,, but it did restart,but still skipped a little. i let it cool for an hour or so went out and restarted it and, i turned on the switch and listened for the fuel pump and it came on a pressured up and shut off. i turn the switch and it fired and ran fine. idled smooth ,,, never happened before.



    terry m

  8. #8
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,466

    Default

    Quote Originally Posted by redchev4x4 View Post
    mine did the same thing today coming in from work,,,, about 90 to 92 degrees outside and after about a 45 minute drive climbing a hill it went to sputtering and skipping,,, i nursed it home and it went dead in the drive going back to my shop,,, i restarted it which it acted like it didn't want too,, but it did restart,but still skipped a little. i let it cool for an hour or so went out and restarted it and, i turned on the switch and listened for the fuel pump and it came on a pressured up and shut off. i turn the switch and it fired and ran fine. idled smooth ,,, never happened before.
    terry m
    well you need pressure gauges to determine fuel pump performance. depending on the fuel required with the engine installed a low pressure can cause engine intermittent run issues as the pressure gradually drops. with a 5.3L engine 50 psi is at a pressure where the engine may run but not very good. 55 psi and higher is best engine running.

Similar Threads

  1. 87 4.3 TBI stalls occiansionally
    By johna20376 in forum Performance & Fuel
    Replies: 2
    Last: 12-06-2011, 02:31 PM
  2. What did you do this summer? Summer Vacation!
    By ChevyFan in forum Sports & Outdoors
    Replies: 14
    Last: 09-06-2010, 08:47 PM
  3. Demand for vehicles keeps GM plants open during traditional summer summer shutdown -
    By ChevyFan in forum Chevy Traverse Forum (GMC Acadia, Buick Enclave)
    Replies: 0
    Last: 06-19-2010, 04:50 PM
  4. 87 Suburban stalls when......
    By burbanguy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 05-07-2009, 01:49 PM
  5. TBI starts then stalls, gas held slowly stalls
    By TigerZ in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 09-02-2008, 02:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •