GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default weird sound coming from engine compartment. need a little help

    I was stopped at a light yesterday when I noticed a weird sound that almost sounds like a fuel pump going bad.
    When I accelerated it was still there but not as noticeable over road noise and such.
    Anyway I got home and sat idle in park hard to pinpoint where it was coming from almost like it was resonating throughout the whole truck.
    Got out walked around got under same thing it could be heard in the front rear cab like I said it was almost like the sound of a bad fuel pump but not as loud. Turned key off and engine gave of a quick purge sound so I tried one quick thing and pulled the drive belt off turned engine back on sound gone.
    I'm thinking one of the parts that uses the drive belt is going bad but witch one? I can't pinpoint any certain part its sounds like the noise could be
    coming from anywhere when the belt is on.

    1999 suburban 5.7 125,000 miles
    any suggestions would be appreciated

  2. #2

    Default

    With the belt off turn each pulley feeling for crunchy feelings and such.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    well I went out and did that turned the pulleys and no crunch sound
    but I did get a whine sound from the pulley at the water pump and I just replaced it a few moths ago.
    haven't had any issues other than that sound think its defective

  4. #4

    Default

    Quote Originally Posted by Pat10 View Post
    well I went out and did that turned the pulleys and no crunch sound
    but I did get a whine sound from the pulley at the water pump and I just replaced it a few moths ago.
    haven't had any issues other than that sound think its defective
    Did the part come with a warranty? Because if it did ask for a replacement one because the new one has a defect. Usually they will give you the new one then ask for the defective. Where did you buy it from?

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  5. #5

    Default

    yes it has a warranty, I put the belt back on let it run and the noise still present of course and when i turn it off it lets out a faint purging whine. but when I rechecked the pulley with belt back off engine warm it would not make the whining sound by hand turning it. idk oh and btw I got the pump at autozone

  6. #6

    Default

    It sure could be the pump, but re-check the idler and tensioner pulleys. they usually are the ones that fail.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  7. #7

    Default

    Quote Originally Posted by RayVoy View Post
    It sure could be the pump, but re-check the idler and tensioner pulleys. they usually are the ones that fail.
    Yeah I'm gonna check those out to I was just going over my receipts and the water pump is about 9 months old. Just hate tearing into things and not being certain. But I guess thats just part of the game sometimes.

Similar Threads

  1. cleaning engine and engine compartment?
    By freddie in forum Detailing & Truck Care
    Replies: 26
    Last Post: 05-08-2013, 11:17 AM
  2. 04 Suburban Weird Whine Like Sound ONLY When Under 20KM over 20 no sound
    By TechAnalyst in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 12-29-2011, 05:20 PM
  3. Weird Noise coming from the back of the truck.
    By tompatt in forum GM Powertrain
    Replies: 3
    Last Post: 12-18-2010, 03:16 PM
  4. Dropped in Engine Compartment!
    By amos1 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 02-10-2010, 09:51 AM
  5. weird hiss coming from dash
    By Micksauto in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 03-23-2008, 10:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •