GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Oil Gauge Problems

    I have a 2004 Chevy Tahoe that the oil gauge bounces around when driving down the road. When it is at idle it appears all is ok. I have replaced the oil sending unit with a new one from o'reilly auto parts and still had problem. so I replaced the dash cluster with a rebuilt one from Dorman and still have the same problem. I have put about 600 miles on vehicle with this problem going on. There is not any noise in engine It runs fine. Any suggestions out there?

  2. #2

    Default

    ****Thread Moved****
    To The
    General Chevy/GM Tech Section


    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    Quote Originally Posted by mholmes View Post
    I have a 2004 Chevy Tahoe that the oil gauge bounces around when driving down the road. When it is at idle it appears all is ok. I have replaced the oil sending unit with a new one from o'reilly auto parts and still had problem. so I replaced the dash cluster with a rebuilt one from Dorman and still have the same problem. I have put about 600 miles on vehicle with this problem going on. There is not any noise in engine It runs fine. Any suggestions out there?
    Can you explain what you mean better? I would love to try and help but I don't fully understand your issue. Also can you tell us what numbers it reads and such.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  4. #4

    Default

    my tahoe oil gauge needle bounces around from when driving down the road. when i am idling the gauge reads a steady 40psi as soon as i drive down the road the needle starts reading all over the gauge but never pegs out but will fall to 0 and low oil pressure will light up and then may go back up to 40psi I replaced the oil sending unit and that didnt stabilize the needle so i put a rebuilt cluster from Dorman in and a still made no difference. the oil gauge is the only gauge that is malfunctioning. I know the pressure is ok because i have made a trip of 600 or so miles on the interstate driving 70 mhp and there isnt any engine noise. the vehicle runs great!

Similar Threads

  1. Gauge Cluster Problems!??!!!!2002 S-10
    By jccraveswaves in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 1
    Last: 10-04-2011, 12:08 PM
  2. Gauge cluster problems
    By ntbush83 in forum GM Electrical Tech
    Replies: 25
    Last: 09-05-2011, 03:07 PM
  3. gauge illumination problems
    By DanZepp in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 06-05-2010, 12:39 PM
  4. 1977 K10 fuel gauge/tank problems
    By prototype51 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 05-27-2010, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •