GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default No Communication from OBDII OBD II OBD 2 OBD2 Port (Cig fuse is good)

    Got a Service Engine Soon light and would like to pull the code. I'm getting +12V power from the OBD connector but my scanner can not communicate. All the wiring in the back of the connector looks secure. Any ideas?

  2. #2
    Jr. Engineer 4x4squared's Avatar
    Join Date
    Dec 2011
    Location
    Fort St. John, BC
    Posts
    224

    Default

    What year is your truck?

  3. #3

    Default

    Quote Originally Posted by 4x4squared View Post
    What year is your truck?
    96' with the 4.3L. I wish I could give you the exact production date but the sticker on the door jamb is worn. I know for a fact is it OBDII because of the sticker under the hood.

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,321

    Default

    How old is your battery? If it is weak your tester might not read the Truck..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  5. #5

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    How old is your battery? If it is weak your tester might not read the Truck..
    I just bought the truck but the battery looked somewhat new. I have over 12v at the OBD port, tested with multimeter.

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,321

    Default

    did you Load test it?

  7. #7
    Jr. Engineer 4x4squared's Avatar
    Join Date
    Dec 2011
    Location
    Fort St. John, BC
    Posts
    224

    Default

    have we tried a different scanner? your scanner might just hate your truck :p



    5.7L 350| .420 Cam | Bored 0.030 | Edelbrock intake manifold | 600 Cfm Edelbrock Carburetor | Long tube headers | Shift kit | Chrome dress up kit | Flowmaster 40's exhaust | Edelbrock heads | Custom paint
    SOLD

    "Don't judge a book by its cover."

    HONORARY CANUCK

Similar Threads

  1. '08 Silverado XM not working "due to communication problem"
    By TurboZ71 in forum Audio, Video & Gadget Tech
    Replies: 2
    Last Post: 08-28-2011, 07:03 PM
  2. OBD2 Software.
    By Atrix88 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 06-12-2011, 12:20 AM
  3. obd2 cable port not working!!!
    By bama2010z71 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 02-08-2011, 09:35 PM
  4. Aux. Port Fuse Search?
    By Smithtad in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 07-08-2010, 08:38 AM
  5. What fuse is my third brake light fuse?
    By b_burdine in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 11-04-2009, 07:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •