GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Default Electrical Issues on my 1987

    hey everyone I am new to this forum and I am not that experienced with the old gmc trucks, I have a 1987 gmc sierra 1500 4x4 305 tbi th350 tranny. I am just trying to fix it up and make it my daily driver. I recently put a new turbo 350 tranny in it since the other one **** the bed on me. I got the tranny in and now the truck wont start. I charged the battery up and made sure there was a charge. I have power to my stereo but there are no headlights or power when I turn over the key. The seat belt and brake light come on when I turn it on and try to start it. I tried toughing a screw driver to the starter to see if there was power going to the solenoid and it turns over that way. If you try to boost it with another car it doesn't turn over not even a noise out of it. I am completely stuck. I checked all the fuses they seemed fine. the only thing I saw but wasn't sure of was the ignition fuse in the fuse panel. there is the normal fuse like a 20A fuse in there but then there is another spot for a ignition fuse that would be like a square one maybe. I could be wrong. Also I changed out the ignition switch today thought maybe that would help, it did nothing. Any help would be great. Thank you everybody.

  2. #2

    Default

    Welcome to the club, it's great to have you aboard. I would have the battery load tested, then have the starter checked and of course check all connections good. Good luck with your project man.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  3. #3
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Welcome to the Club!!!

    I move your thread to the correct section of our forum and changed your title to match your topic. This will help in getting you more responses/opinions.

    Sorry, out of my realm, thus do not have any suggestions....


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  4. #4

    Default

    Try looking into the neutral safety switch circuit. This is the circuit that won't allow the car to start if the transmission is not in Park or Neutral. I had a Dodge minivan that had the neutral safety switch connector on the transmission housing. The circuit connector backed out of the the connection on the tranny housing just enough to break the circuit and my van wouldn't start. Right when I was leaving for work, too! Took me half the next day to figure out what was going on and track it down. But some of the other symptoms I had were similar to yours. The lights would come on, and when I would turn the key the radio and dash lights would go out like it was preparing for the engine to crank, only it didn't. When I bypassed the circuit and jumped the starter directly, the van started.

    Check all your connection for the Neutral safety switch circuit, and then check all the fuses and relays for the same circuit.

    My two cents.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

Similar Threads

  1. 1987 surburban electrical issues
    By roywfields in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 06-15-2012, 02:48 PM
  2. Electrical Issues
    By horsemanmike in forum GM Electrical Tech
    Replies: 3
    Last: 07-22-2011, 09:44 AM
  3. 1987 Suburban Electrical Issues
    By bigdaddyforge in forum GM Electrical Tech
    Replies: 10
    Last: 10-18-2010, 09:25 PM
  4. Electrical Issues
    By Joethepoolguy in forum GM Electrical Tech
    Replies: 7
    Last: 03-21-2010, 09:28 PM
  5. Electrical Issues
    By focal318 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-29-2009, 10:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •