GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 2002 Silverado 4x4 5.3 bogs at take off

    I just bought this truck. It seems to run fine but when you take off from a dead stop it will bog for a few seconds then when it goes its slow. If im running 40 and stomp it it shifts down and goes like it should also im only getting 11.25 mpg . The check engine light is on and I was told it was the wheel speed sensor left front and knock sensor. Ive cleaned the maf sensor, trottle body air filter good spark plugs good can someone help

  2. #2

    Default

    Change the knock sensor first, that will change the fuel tables and spark timing and help you out. Also check out the fuel pressure.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


  3. #3
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,489

    Default

    you MPG is tooo low. with normal average driving you should get 15-16 MPG. on the hyway 18-19 MPG 75 MPH max, speed.

    washing the engine is a no no with these engines, the upper intake has a GM defective seal. water /soap/chemicals enters this area and causes the knock sensor [s] to fail.

    random missfires could be plugs. only use ac delco irridiums . the other items would be fuel delivery issues. fuel pressure readings and a fuel pressure test to make sure the regulator and injectors are operating properly.

    being over 10 years old replace the ECT sensor. this can cause fuel mixture issues .

    if the vehicle has not been properly maintained the cat converters may be restricted so check the back pressure. good luck.

  4. #4

    Default

    Thanks for the replys im gonna try to do the knock sensors monday I noticed I got the parts store to clear the code for me witch was just the knock sensor now and it took off very well even spun the tires a little but the light came back on and it started doing the same as it was . What is the ECT sensor. The truck seems as if it was took care of pretty well but as of now ill work on getting the knock sensor replaced is there any advise yall could give me on it

  5. #5
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,489

    Default

    The ECT is the temperature sensor that is mounted on the driverside of the engine forward. this tells the PCM what the engine temp is. these go bad/out of cal and throw off the engine fuel management., 10 years old is about it on a accurate feed to the PCM. costs about 15/20 USD.

    I have heard of this KS failure with a new purchase this is probably from the AUTO sales business washing the engine bay down.

    GM did put in the manual not to wash the engine .

  6. #6

    Default

    Sorry to take so long to get back on here but I replaced the knock sensors and all seems fine now thanks for the advise

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •