GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Unhappy TBI starts then stalls, gas held slowly stalls

    about 3 months ago my truck needed to pass smog, but i was throwing a code (it was EGR valve). I replaced the valve, light went off, then it passed smog with flying colors.

    The truck ran fine before and after the new EGR valve.

    Now over the past like 2 months I've had a weird idling problem with this truck. it would idle low 400-500 rpm then ALMOST stall and then not. i figured it needed a good tune up. so i went about replacing the obvious.

    IAC Valve
    PCV valve
    K&n filter
    royal purple oil
    MSD coil
    accel cap/rotor
    OEM plugs
    wires were inspected and look and tested fine.

    still the same problem. i was never really able to pinpoint the issue, and as time to work on it was tight. i had to live with it.

    Now about 2 weeks ago, out of absolutely NOWHERE my truck just died in the middle of driving. First instinct - OIL!!! i hadn't checked it in a little while. I immediatly pulled over and checked it, oil level was perfect. I was only about 3-4 miles from home so i drove there. The engine would not stay idling, it would stall at idle and if i held the gas down at say, 2500 rpm, it would stall itself out in a few seconds. i had to feather the gas at every signal and while accelerating.

    FINALLY i made it home wondering WTF happened. My engine was throwing no codes and i had no idea what was wrong. I read through my Haynes manual and started from there.


    MAP sensor
    TPS sensor
    new plugs
    new fuel filter
    new fuel pump
    fuel pressure regulator
    distributor
    ive ran a compression test.
    all cylinders are pretty much even.
    spark is nice and strong
    all hoses have been inspected
    EVERY smog sensor or actuator has been swapped out with a new one for testing and made no difference.
    ALL fuel system components have been replaced.

    I noticed all my coolant had disappeared, which was the reason for the compression test. However, my engine has NEVER even came close to overheating. If anything it runs pretty cool @ 160-170. I ran the compression test. Nope. all cylinders were fine. I drained the oil, oil looks normal. I pulled one of the valve covers, theres oil in there and all rockers are tight and no springs are broken.

    As of two days ago my oil gauge shows NO oil pressure, ZERO. If anything, the guage rises a little when its shut off. i don't know if maybe i disconnected something or what. I checked the level and its normal. Ive ran the engine a couple times and i haven't heard anything new. If its just a gauge i could really care less, i just need a running truck. Giving people gas money to drive way out of their way is just killing me right now.

    I'm now at a total loss, and i am considering giving up and having it towed to a shop, but i really don't have the money for that right now.



    Thanks for the responses.
    -TIGERZ
    Last edited by TigerZ; 05-13-2008 at 01:34 PM.

  2. #2

    Default

    im having the exact same issues on my 88 2500 silverado 2wd 350 tbi might i ask what engine it was and what year and model and if you figured out how to fix it or if anyone else has had this issue in the past and what they did to fix it

    i have changed my tps switch my egr valve the spark plugs the oil the fuel filter im at a loss and would like to figure it out without spending more money than what i paid for the truck

    a friend said he had the same problem with his 91 blazer with a 350 in it and all he had to do was change the tps switch and it worked fine afterwards but i have already chaged that with a brand new one and nothing changed.
    Last edited by BigRed2500; 08-31-2008 at 05:49 PM.

    Mine
    BIG RED-1988 Chevy Silverado 2500 350 cbi 2wd
    eater of gas

    My Wifes
    HER BABY-2000 Chevy S-10 4 banger flex fuel 2wd
    saver of gas

    Father in laws
    TOM DUALLY-1993 Chevy Silverado 3500 dually diesel banks power pack
    Hauler of Trailer

    LIL RED-2001 Chevy S-10 4 banger flex fuel 2wd

  3. #3

    Default

    hey, turned out i had a freak accident with my timing gear and an entire tooth got ripped



    still to this day no one knows how that happened. There is barely and wear on the gear.


    i went through the phone book and found a shop that had a flat-rate diagnostic fee. i took it to them and for $65 it was their problem. 3 hours later they called me and told me what was up. i wish i had done that from the beginning.


    Hope this helps.

Similar Threads

  1. Stalls on 1/4 tank
    By wl_walker in forum Performance & Fuel
    Replies: 6
    Last: 07-29-2009, 12:57 PM
  2. Stalls on low fuel
    By route66paul in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 02-28-2009, 10:06 AM
  3. engine stalls
    By gregk in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 06-27-2008, 09:48 AM
  4. hard starts and stalls
    By leother in forum GM Powertrain
    Replies: 9
    Last: 09-26-2007, 09:29 AM
  5. Starts but Stalls out
    By mcrich in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 04-09-2007, 09:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •