GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Question Persistent Perplexing Problem with my Pickup

    Hello, I was wondering if one of your techs could help me with a problem I have with my 1992 Chevrolet C-1500: 2WD, 5.7L, 700R4. About 3 weeks ago I was driving through town and my pickup stalled in traffic and would not start. Called AAA and had it towed home. Thought it to be a clogged fuel filter. Replaced the filter and also ran the code scanner, flashed a 54 code for a bad fuel pump relay. Also replaced the relay. Started the engine, it ran fine, went into town again (about 15 miles) made a couple stops, engine started each time.

    After the 2nd stop, I was driving along, approached a stop sign, engine stalled, would not start. Called AAA again, towed home...again. Sitting out in the yard, when engine cold, it will start and run smooth about 10 minutes until engine warms up to operating temperature, then it stalls and will not start again until engine cools off completely. Checked for ignition spark and fuel pump pressure immediately after stalling, have both, also checked codes, have none, other than #12, signalling everything ok, which it most definitely isn't. I have very little experience with vehicles made after 1980...Please help...

  2. #2

    Default

    One thread is probably best, than all answers can be inside it.

    http://www.gmtruckclub.com/forum/sho...-Ain-t-Running
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •