GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Electrical Problem

    I have a 2002 Chevy Suburban 1500 4x4. I have been experiencing some sporadic electrical issues when starting my truck in the morning. It started last fall (2012) after work. I got into my truck and turned the key to start it. When I turned the key my gauges went crazy and stuck in a position, had no power to the dash, and the engine did not crank over at all. After I turn the key again it started. Later that day I was @ a hardware store with my wife. When we were leaving it did the same thing. This time I popped the hood to take a look at the fuses and found nothing. After I closed the hood, my wife said my gauges all jumped. I went to start it and it ran fine. I called my wife's uncle who is a mechanic and was suggested I check the battery connections to make sure they were tight. Which I did. It would do it a few more times then go away for several months. Now it has reared it's ugly head again. Now when it happened recently (this morning) I turn the key and got nothing. My gauges goto a quarter (fuel gauge) and stop. I open my door and close it, put the key in the ignition and my gauges bounce. Still nothing. Pop the hood close it and the truck runs rough and stops. Turn the key again and it runs like a champ and it will run fine for the rest of the day. I did have it in the shop a few weeks ago where they tried resetting the key memory 3 times to no avail. I was told to try this again or try using my spare key which I will be doing next. I don't know it I'm having a ground issue or an ignition module issue. Could use some help with this. It's pissing me off to say the least.

  2. #2

    Default

    Crazy,
    I am having similar issues today with my 2004 Suburban. Keyless would not work so manually opened door. Started car but it died after 2or3 seconds. Started again and ran but no guages except tach worked and ABS and battery lights stayed on. I shut it off and have not run it since. Did you resolve your July issue? Any ideas from anyone? Thanks for any help.

  3. #3

    Lightbulb My problem is fixed. Your problem is what I thought caused my problem.

    Quote Originally Posted by tdubdub View Post
    Crazy,
    I am having similar issues today with my 2004 Suburban. Keyless would not work so manually opened door. Started car but it died after 2or3 seconds. Started again and ran but no guages except tach worked and ABS and battery lights stayed on. I shut it off and have not run it since. Did you resolve your July issue? Any ideas from anyone? Thanks for any help.
    My problem was my battery cables were 3/4 of a turn loose. The problem you are having I read some where (these guys had the exact same problems) that it may be your ground wire in the engine compartment. I noticed there are two ground wires on the driver side just above the master cylinder. Some people had a short or separating of the ground wire. For some reason some people had ground wires that were too short and just needed a little extra length. They noticed their truck would run then die when driving over railroad tracks or potholes. One guy was able to trace it from the plug under the steering column (the one they use to read error codes) to a ground that is on the back of the engine on the passenger side. If it's not that, it may be your ignition module going to ****.
    I have had a problem with my wife's key fob in her 2006 Malibu. Only the trunk button would work. We had to replace it with new one I got on Amazon for $11 - $15. You just have to get it programmed by someone. Some auto shops have code readers that can reprogram the new fob.

  4. #4

    Default

    Crazy,
    Thank you for your response. I'll start checking my connections.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •