GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Hi y'all! Please help??

    Hi all! Good to be here! I'm a member on the Honda VTX motorcycle forum and have had AWESOME luck with tech questions there. Here goes. 2003 1500 ext. cab Z71. Great truck, but it's killin' me lately! Water pump gasket leak, intermittent failure of the keyless entry, and now the engine light is on! (and I need a brake job!) I'm almost broke and need (and want) to do this stuff myself. Scanned the computer and it tells me there is a large evap system leak. I checked the gas cap and it seems fine. Where else should I be looking before I spend the dough on diagnostics at the shop or the stealer? I truly appreciate any suggestions.

  2. #2

    Default

    well the water pump gasket aint that bad you can get a new water pump from napa for cheap and its not that hard to put on... I would replace the gas cap just to be sure its not that expensive either, it may look fine but you never know
    PETE
    95 GMC Sierra 2500
    3" Body Lift, 33" Goodyear MTR's
    5.7L 350 TBI Edelbrock SDT Exhaust, Flowtech Headers, K&N Intake
    Sold :(
    1999 Jeep Cherokee, 3" Rustys lift, 33" BFG MT's, locked, armored: Rolled :(
    2000 Jeep Grand Cherokee Limited. K&N Intake, Custom Kolak Exhaust


    Contact this GMTC Moderator for any problems or questions you may have :great:

    Join the GMTC Facebook Group!!! Join Here

  3. #3
    Jr. Engineer Gmcsuvguy's Avatar
    Join Date
    Dec 2007
    Location
    Alberta, Canada
    Posts
    279

    Default

    It's pretty hard to test the evap system yourself, change yor gascap, look at all the evap lines for cracks or disconnected, other than that it is a dealer diagnosis. Good-luck!
    Ken Beida
    2010 GMC Sierra Crew Cab 4X4, 5.3L
    2009 GMC Sierra Denali, 6.2L = 403hp, AWD, Full load

  4. #4

    Default

    Thanks folks! I'll give it a try and hope for the best.

  5. #5
    Jr. Apprentice
    Join Date
    Oct 2007
    Location
    north of Boston
    Posts
    12

    Default

    I have a evap problem - replaced the cap - dealer -by vin#, evap sol. valve ...
    how did you make out w/ yours??

  6. #6

    Default

    most of these things are easy and do it yourselfers....i make sure it is the gasket or the water pump there is a small hole and it water is comming out it it is the pump. this is a 20 min swap job and get a new serp belt and thermastate (i used a 160 degree and got 4 mpg increase) i replace the gas cap and rerun the test i bet the seal is bad on it. you might put some grease on the old cap seal and see if that makes it pass the test if so get a new cap or look at the evap system lines.
    brakes are easy i just did a writeup on the front end took 30 min to swap out the front pads and 45 min for the rear shoes, i think yours are disc so it is faster. then reply with your results and we will help or if fixed allow someone searching to see what worked....mike
    Michael Collins
    1993 4X4 Suburban
    many other toys as well

Similar Threads

  1. Hi Y'all!
    By retired2001 in forum Member Introductions
    Replies: 6
    Last: 04-08-2010, 10:05 PM
  2. Howdy Y'all
    By Brig in forum Member Introductions
    Replies: 11
    Last: 04-15-2009, 01:54 PM
  3. Hi Y'all
    By jn1965 in forum Member Introductions
    Replies: 9
    Last: 01-16-2009, 08:11 AM
  4. hey y'all
    By tips in forum Member Introductions
    Replies: 11
    Last: 07-22-2008, 07:43 PM
  5. greetings y'all
    By walker43 in forum Member Introductions
    Replies: 4
    Last: 10-17-2007, 01:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •