GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default HELP! Engine RPMs surging when driving

    Hey guys, my 2010 5.3 AFM Silverado w/66,000miles has been RPM surging while driving over the past couple weeks.

    It seems to happen primarily when traveling between 45-55mph. When driving, slightly accerating, the truck is doing about 1100 rpm in its 6th gear. The engines RPMs seem to bounce back and forth 50-100 rpm.

    It is not the usual 'bounce' you get from v4 to v8 mode, it is happening while accelerating which i can see is keeping it in v8 mode. To add to it, it is no happeing in really any other gear or driving condition. Go faster with more rpm, problem gone. Its seems to only show when "lugging' in the low rpm when locked into the high 6th gear.

    A friend suggested good gas, some sea foam and a throttle body cleaning. I am worried it has to do with my tranny and torque converter, could something be wrong with it?....if so, why only at that speed and gear?

    Please help if possible, thanks in advance

  2. #2
    Newbie
    Join Date
    Jul 2013
    Location
    Hopkinsville Kentucky
    Posts
    4

    Default

    Check your tranny fluid, if its black or smells burnt you have probably burn up your band. Not really sure about your truck but thats what happened with mine and I eventually had tranny rebuilt but I took mine to the wrong guy and today my tranny went out, so double check the reputation of the place or person you take it to

  3. #3

    Default

    Quote Originally Posted by alkaspeltzar View Post
    Hey guys, my 2010 5.3 AFM Silverado w/66,000miles has been RPM surging while driving over the past couple weeks.

    It seems to happen primarily when traveling between 45-55mph. When driving, slightly accerating, the truck is doing about 1100 rpm in its 6th gear. The engines RPMs seem to bounce back and forth 50-100 rpm.

    It is not the usual 'bounce' you get from v4 to v8 mode, it is happening while accelerating which i can see is keeping it in v8 mode. To add to it, it is no happeing in really any other gear or driving condition. Go faster with more rpm, problem gone. Its seems to only show when "lugging' in the low rpm when locked into the high 6th gear.

    A friend suggested good gas, some sea foam and a throttle body cleaning. I am worried it has to do with my tranny and torque converter, could something be wrong with it?....if so, why only at that speed and gear?

    Please help if possible, thanks in advance
    Hello,

    I see that you are experiencing an issue with your vehicle. Please private message if I can be of any assistance.

    Safe travels,

    Jennifer T.
    GM Customer Care

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •