GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Question Going Crazy... ECM 1 fuse Blows!

    I can't find my problem, and I'm going crazy. 1990 V2500, normally run perfect.

    On the road last week, and it died. get it home, check fuses... ECM 1 blown. replace..turn key to On position... blows again.

    Before the fuse blows, I can hear fuel pump relay click but no fuel pump prime. I decide to change fuel pump & injector relays, anyway.

    I have traced all wiring, everything seems OK. injectors wires good. did the process of elimination with sensors, unplug/plug in... still blows.

    I've also unplugged fuel pump, coil & ECM...and the fuse still blows! What am I missing?

    HELP! please

  2. #2

    Default

    Copied from another forum...
    1. "ecm power wires on passenger side of engine ground out to the exhaust, pull awasy, and check for damage, my 97 kept popping fuses, and this fixed it"
    2. "The problem is almost certainly a fuel pump wire harness short, caused by a dying fuel pump. I have both had this problem myself, and repaired it on three other vehicles. On my vehicle, the wire harness had welded itself together when the fuel pump locked up, and the wire harness caught on fire."

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •