GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Sr. Apprentice AKRide907's Avatar
    Join Date
    Mar 2011
    Location
    Fairbanks, Alaska
    Posts
    50

    Default ZX3 Electronic Suspension

    So I just found out that my truck has got the zx3 electronic suspension. The truck has 127K miles on it, pretty much rides like ass regardless of whether or not the zx3 assist is on or not. Just curious what everybodys thoughts are on trying to get OE parts installed new or just use something aftermarket. Didnt actually even occur to me that I had it until i got under the rear and start unbolting one of the shocks when i noticed a plug going into the top of the thing.
    AkRide907 - Milaud
    2003 Chevy Silverado 1500HD Crewcab 6.0L
    Quadrasteer, K&N Cold Air Intake, Catback True Dual Exhaust
    "Welcome to Alaska... where its cold as f**k, and we go hard with our trucks."
    Next project: Install Long Tube Headers w/custom header back exhaust pipes

  2. #2

    Default

    I would say use factory for the ZX3 suspension...its gonna be more than aftermarket but least you know they will be built right(maybe)

    2009 Chevrolet Silverado 1500 LT Z71 Crew Cab "All-Star Edition"

    Line-X'd Bed
    Line-X'd Custom Brush Guard(Heavy Duty)
    5.3L Flex Fuel
    275/65R18 Toyo Open Country AT2's
    2" Rough Country Leveling Kit(want to get the 2.5 RC kit)
    EGR In-Channel Vent Visors
    Exterior PLUS Package
    Interior PLUS Package
    K&N Drop-In Air Filter
    ProFlaps
    Cat-Back Dual Exhaust
    Black Bowties
    Diablo Sport Predator(AFM Disabled)
    ProFlaps
    Towing Mirrors
    Next Planned Mods
    Blacked out Tail Lights
    Aftermarket Rims

  3. #3
    Sr. Apprentice AKRide907's Avatar
    Join Date
    Mar 2011
    Location
    Fairbanks, Alaska
    Posts
    50

    Default

    No kidding they were more expensive. Went straight to the chevy dealership in town and asked their service desk and they said they could order them for me for a grand per pair!! I talked to one of their mechanics and he said the worst that could happen if i dont use the OE parts was that the computer might tell me that the ride assist wasnt working properly. So i got a pair of monroe reflex's for the rear and a pair of monroe spectrum's for the front. So far so good, no computer warnings... and i swear that the truck has not ridden that smoothly in the five years since i bought it from my dad.

    But for info, apparently the electronic shocks for the ride assist are gas operated. The computer sends a signal/current to each of the shocks and the current causes the gas to expand (or in the absence of current contract?). That was my understanding of how the mechanic explained it to me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •