GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Headlights Aren't turning on. HELP

    Hey everybody,
    I have a 1982 K10 and a while ago my headlights stopped working so I took some steps to fix it and nothing has fixed it. I have replaced the switch and had the ground coming off of the engine block and the negative ground replaced. That didn't work. I'm stumped I just don't know what to do. Fuse is good. Oh and one more thing, I have KC lights and there is an inline fuse under the dash for them and when I flip the switch the connection gets very hot and smokes so I have no lights..... If someone could help me with both that would be great. Oh and the highbrights don't work.....

    Thanks,
    Crockpot

    1982 Chevrolet K10 Scottsdale
    5.0 Liter 350 Short Block
    Automatic/4WD35-Inch Tires
    15-Inch Micky Thompsons / 6 Inch Suspension Lift

  2. #2

    Default

    Stupid question, but have you checked the head lights bulbs?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    As far as the headlights go - have you checked for inline relays after the headlight switch that could be bad?

    On your KCs - it sounds like you have all the current for the lights going through a wire that is too small for the load. Up the wire gauge.

    My $0.02.
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •