GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1
    Jr. Mechanic Bowtied's Avatar
    Join Date
    May 2009
    Location
    2004 Silverado 5.3L
    Posts
    132

    Thumbs down Excessive Popping from New Tie-Rods (Front Left and Right)

    Hello all,

    I have an excessive amount of popping coming from the tie-rods (I assume) that were just replaced on my 04 , I am suspecting that the mechanic did not lube or grease or whatever the tie-rods at all since the sob on both sides is popping 3+ times per wheel turn (from lock to lock) even in motion.

    Is this an easy area to access and lube or does it require a removal of the tire?

    Also, now that i've been given my truck back the gear shift lever is extremely "loose" even in drive there is lateral play, and in park or 1 you can wobble the lever as though it were a joystick, definitely not how i gave it to him, wondering if there is some sort of linkage down there that would cause this issue.

    Thanks for any advice,

  2. #2
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    the lower pan needs removal. a grease gun with a 90deg fitting helps get to these . grease until the boot swells slightly. the tie rod seals should not allow grease to come out. the seals need be properly secured. while your down there see the tranny linkage connection for part tampering. the cable may have been taken and used in another vehicle.

    owners that like to play with the shift lever constantly will have this problem , it is not designed for this amount of work .

    use lithium based grease.

  3. #3
    Jr. Mechanic Bowtied's Avatar
    Join Date
    May 2009
    Location
    2004 Silverado 5.3L
    Posts
    132

    Default

    its funny you should mention that the linkage may have been taken and used on another vehicle because that was the first thing i had in mind.

    Also, since the dash or gear indicator on my 04 is electronic, would a faulty shift linkage not be as profound or noticeable as it was on my last truck which had an "analog" gear position indicator (when linkage was off, "P" was "R", "D" was "Low" etc. very obvious) , when i first googled the shift lever issue i came upon this:
    http://67-72chevytrucks.com/vboard/s...d.php?t=341677 which to me doesnt seem likely as there was no repair in this area, only down at the tie rod.

    EDIT: Also, forgot to mention both the inner and outer tie rods were replaced on both wheels, i am not familiar with how these are replaced but am watching you tube videos on this now, i am really not that happy about this.

  4. #4
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    dirty larry did a great write up on that. I thought that the shift cable was the problem as with the slightly older trucks did have this issue. with yours it must be that bushing. like he said you could make one up, using some tubing and flaring the end.

  5. #5
    Jr. Mechanic Bowtied's Avatar
    Join Date
    May 2009
    Location
    2004 Silverado 5.3L
    Posts
    132

    Default

    Quote Originally Posted by j cat View Post
    dirty larry did a great write up on that. I thought that the shift cable was the problem as with the slightly older trucks did have this issue. with yours it must be that bushing. like he said you could make one up, using some tubing and flaring the end.
    Well, the cable for the shift linkage needs to be checked, what i was wondering is, if linkage is off will it show on the electronic gear position indicator in the dash or, if linkage is correct electronically does this rule out that cable?

  6. #6
    Legend

    Join Date
    Sep 2010
    Location
    everett, massachusetts
    Posts
    1,323

    Default

    Quote Originally Posted by drwombat View Post
    Well, the cable for the shift linkage needs to be checked, what i was wondering is, if linkage is off will it show on the electronic gear position indicator in the dash or, if linkage is correct electronically does this rule out that cable?
    with the shifter in park the bushing I would think is the problem. I would still check the cable at the tranny to see if they messed with it. that would be easy to see. or perhaps they some how damaged it when they lifted the vehicle etc.....

  7. #7
    Jr. Apprentice 4by44ever's Avatar
    Join Date
    Nov 2010
    Location
    begium,stekene
    Posts
    24

    Default

    Next time,i now im naging,but next fix things yourself as mutch as posible,a hannes manual goes a long way.
    And that way,if something is done wrong,you will know what.
    i'm also thinking colatoral damage from for example lifting,if parts are replaced with a broken ones,man,i think i would go nuts.

  8. #8

    Default

    Are you sure that it is the tie rods popping and not the intermediate shaft that needs lubed?

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  9. #9

    Default

    Yea "popping" sounds like a steering shaft issue.
    01' 1500 LT Z71 ECSB 5.3L
    line-x'd front brush guard with KC Daylighters, 6000k HID lows and highs, rewired highbeams, Trans-go mild shift kit, custom stainless duals, 3500 dually OEM taillights, K&N CAI. Still have OEM fender flairs and leveling kit in boxes waiting for time.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •