GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Brake light and park assist issues

    I have a 07 gmc sierra z71 crew cab. 5.3 I am having issues with my brake system and park assist sensors. Occasionally when i apply the brakes, the "brake" light will flash and the ding ding alert will sound. AND the "park assist off" comes on the display.
    I had my hitch on for a while and was used to turning the park sensors off, but the brake light is throwing me for a loop.
    Brake fluid is at proper level

  2. #2

    Default

    Powertrain codes and smog codes will cause the Check Engine Light to come on, indicating there is a code in memory. Other control units will also store codes, but sometimes will not light the CEL, instead, lighting the light associated with the system that has the fault. I would go somewhere to have the code(s) read.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Quote Originally Posted by bigdave367 View Post
    I have a 07 gmc sierra z71 crew cab. 5.3 I am having issues with my brake system and park assist sensors. Occasionally when i apply the brakes, the "brake" light will flash and the ding ding alert will sound. AND the "park assist off" comes on the display.
    I had my hitch on for a while and was used to turning the park sensors off, but the brake light is throwing me for a loop.
    Brake fluid is at proper level
    I am sorry to hear that you experiencing an issue with your vehicle's brake system and park assist sensors. Private message me if I can be of any assistance.

    Safe travels,

    Jennifer T.
    GM Customer Care

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •