GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default cruise control...

    guys ive been stumped for months with my cruise control not working...
    ive heard all sorts of things from fuses (duh , ive checked those, theyre fine) to hearing things about having led tails and 3rd brake light leds... but i cant really remember if thats when my cruise control stopped working...

    question:
    should the "Cruise" light, light up when you start your vehicle?
    mine does not, if that points a possible cause

    usually when i turn cruise control on, the word "cruise" lights up, regardless of whether im using it or not, then if i choose to engage it, the word "on" lights up, which stays on until you turn cruise off, or tap the brake....
    my problem is, "cruise" does not even come on when i push the switch, no quick flash, short circuit or anythings, just doesnt come on...

    can anyone help out?
    thanks
    2000 Chevrolet Silverado

    Powertrain:
    4.3L V6, 4L60E, 2WD, Single Cab
    Performance:
    Airaid CAI
    Poweraid TB Spacer
    Flowmaster 10-series exhaust (dumped)
    BLACKBEAR TUNED!!!
    Edge CS insight monitor
    4.10 gears
    Limited-slip differential
    LS-1 Dual Electric fans
    Corvette tranny servo swap

    Audio:
    Head Unit: Alpine
    Speakers: Alpine SPR-60C 6.5" component set, 4X6 Infinity Kappas
    Subs: 2-12" Kicker CVT's
    Amps: Alpine-M1000 (subs), Alpine MRX-F65 (Speakers)


    Tires/Wheels:
    305/70R16 NITTO Terra Grapplers
    16" PROCOMP 7089's
    Suspension:
    2" leveling kit
    3" Fabtech Spindle Lift Kit
    Front/Rear-Bilstein 5100 shocks

    Lighting:
    FRONT
    35W HID Low Beams
    RECON LED smoked roof cab lights
    REAR
    HELLA LED taillights and 3rd brakelight
    HELLA FF-75 Aux. Reverse Lamps
    RIGID dually D2, flush mount, wide beam
    Accessories:
    Hawk HPS Brake pads
    Russell braided steel brake lines
    Powerstop-red powdercoated brake calipers
    Powerslot Cryo brake rotors
    EGR in-channel window visors

  2. #2

    Default

    Ive seen the cruise control stop working correctly after swapping both taillights and the CHMSL before, Altezza taillights seem to be worse than most for messing up the taillights.
    Id probably install the factory taillights and 3rd light first to verify that wasnt the problem.

  3. #3

    Default

    Quote Originally Posted by tbplus10 View Post
    Ive seen the cruise control stop working correctly after swapping both taillights and the CHMSL before, Altezza taillights seem to be worse than most for messing up the taillights.
    Id probably install the factory taillights and 3rd light first to verify that wasnt the problem.
    but when this happens, does it disable all of cruise control? or does "cruise" still come one but not the "on" light to engage it?
    2000 Chevrolet Silverado

    Powertrain:
    4.3L V6, 4L60E, 2WD, Single Cab
    Performance:
    Airaid CAI
    Poweraid TB Spacer
    Flowmaster 10-series exhaust (dumped)
    BLACKBEAR TUNED!!!
    Edge CS insight monitor
    4.10 gears
    Limited-slip differential
    LS-1 Dual Electric fans
    Corvette tranny servo swap

    Audio:
    Head Unit: Alpine
    Speakers: Alpine SPR-60C 6.5" component set, 4X6 Infinity Kappas
    Subs: 2-12" Kicker CVT's
    Amps: Alpine-M1000 (subs), Alpine MRX-F65 (Speakers)


    Tires/Wheels:
    305/70R16 NITTO Terra Grapplers
    16" PROCOMP 7089's
    Suspension:
    2" leveling kit
    3" Fabtech Spindle Lift Kit
    Front/Rear-Bilstein 5100 shocks

    Lighting:
    FRONT
    35W HID Low Beams
    RECON LED smoked roof cab lights
    REAR
    HELLA LED taillights and 3rd brakelight
    HELLA FF-75 Aux. Reverse Lamps
    RIGID dually D2, flush mount, wide beam
    Accessories:
    Hawk HPS Brake pads
    Russell braided steel brake lines
    Powerstop-red powdercoated brake calipers
    Powerslot Cryo brake rotors
    EGR in-channel window visors

  4. #4

    Default

    Dont remember, been a while since I had to work on a vehicle with that problem.
    I think the light came on but the cruise wouldnt engage.

  5. #5

    Default

    update on my problem...

    after playing around with everything, I realize that if i UNPLUG the connector from the cruise module under the hood and plug it back in, then try to turn on cruise while sitting there parked, itll flash for about one second then go away.
    does it everytime i unplug and replug the connector to the module, but no other time...
    does this indicate my module is bad?
    2000 Chevrolet Silverado

    Powertrain:
    4.3L V6, 4L60E, 2WD, Single Cab
    Performance:
    Airaid CAI
    Poweraid TB Spacer
    Flowmaster 10-series exhaust (dumped)
    BLACKBEAR TUNED!!!
    Edge CS insight monitor
    4.10 gears
    Limited-slip differential
    LS-1 Dual Electric fans
    Corvette tranny servo swap

    Audio:
    Head Unit: Alpine
    Speakers: Alpine SPR-60C 6.5" component set, 4X6 Infinity Kappas
    Subs: 2-12" Kicker CVT's
    Amps: Alpine-M1000 (subs), Alpine MRX-F65 (Speakers)


    Tires/Wheels:
    305/70R16 NITTO Terra Grapplers
    16" PROCOMP 7089's
    Suspension:
    2" leveling kit
    3" Fabtech Spindle Lift Kit
    Front/Rear-Bilstein 5100 shocks

    Lighting:
    FRONT
    35W HID Low Beams
    RECON LED smoked roof cab lights
    REAR
    HELLA LED taillights and 3rd brakelight
    HELLA FF-75 Aux. Reverse Lamps
    RIGID dually D2, flush mount, wide beam
    Accessories:
    Hawk HPS Brake pads
    Russell braided steel brake lines
    Powerstop-red powdercoated brake calipers
    Powerslot Cryo brake rotors
    EGR in-channel window visors

  6. #6

    Default

    It could be the tail lights. On my 05 the cruise light will not come on unless I am going over 25mph. Then I have to press the set button for it to light up. The other day I was towing an old trailer from work. I set my cruise and it kept shutting off over bumps. I could not figure out what was going on. I disconnected the trailer lights and the cruise has worked fine since.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •