GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11

    Default

    Yeah that's true. Didn't really think that through. Making the knock sensor change now. Pain in the asthma right now.



    If at first you don't succeed, get a bigger cheater bar.

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 "Vortec" | Spectre "Cold Air Intake" | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tail Lights | Denali headlights | Grill Mounted Fog Lights | AWS Bug Shield | 265/70/16 Futura Scramblers | Boss HD Speakers | 2005 Overhead Console | Flowmaster Super 40 mufflers 2N1O | Mostly stock-ish
    Future:
    Bigger Amp Alternator | Electric Fans | Transmission Fluid cooler | Paint (Halfway there)| Interior Restoration/Upgrade with newer model parts | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations (68% Done) | And whatever is spurr of the moment
    CVN-69 "IKE-ATRAZ" AIR/V-2 Gear Dawgs

  2. #12
    Jr. Engineer
    Join Date
    Aug 2010
    Location
    eas' bum fuk, maine
    Posts
    207

    Default

    Quote Originally Posted by dedmon27 View Post
    Mine went about two years ago, but it was completely my fault. I was out of town for work for about two weeks. Knowing when I got back I had to change the oil and stuff. So when I returned and started to add the oil I noticed a nice mouse nest under the intake. So I took my pressure washer and sprayed the heck out of it. Needless to say about a day later Check Engine light on. Scanned and sure enough Knock sensor. So I replaced them both, yep under water. So I used silicone to seal the ports when I replaced the covers. Anyway anytime your check engine light (CEL) is on you lose fuel economy. After your vehicle reaches operating temps it goes into "closed loop" meaning the computer reads all the sensors and adjusts the way your engine runs. CEL on means your vehicle stays in "open loop" and runs off pre set perameters in the computer, hense lower MPG's.
    depends on what code sets or what sensor fails. if maf or o2 sensor (etc) fails then yes its stuck in open loop because it NEEDS those sensors to be in closed loop. if its just an evap code setting the light then close loop is still going to function.

    Quote Originally Posted by rileyjr16 View Post
    Well i now have some water dropping out of my exhaust pipes so... Gotta change those head gaskets anyway.
    good rule of thumb... for every gallon of gas burned, a gallon of water is produced.
    "i dont think you got the picture. i got a beautiful picture. this baby happens to have an extra turn of speed, which is the only thing i care about. you dont understnad what happens do you? they make cars. they make 'em exactly the same way. one or two of 'em turn out to be something special. nobody knows why. i know why. i may be kiddin' myself, but i think i can make somethin' out of that sad little bucket of bolts." ~ Tennessee Steinmetz

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •