GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Default Seafoamed the Av

    So today I decided to Seafoam the Av to see if that would help out with the gas mileage. I put about 1/3 of a can through the brake booster vacuum line and shut it off for about 15 minutes. When I started it back up I was expecting some huge cloud of smoke like in all the videos I've seen but all I saw was a tiny little bit of white smoke and then it was gone. Did I do this improperly? Should I have put in more seafoam or was my intake system already clean to begin with? I think I might also go buy the spray bottle for the throttle body and use that.. What are you guys thoughts?

    08 Av 5.3L w/ 70k miles. New plugs and new wires.
    -2008 Chevrolet Avalanche LT 4x4 w/ K&N CAI
    -2012 Kia Soul !
    -2003 Kawasaki Ninja ZX-6R 636

  2. #2

    Default

    I believe I read somewhere that SeaFoam has created a no or low smoke version, check the can to see if it mentions this.
    Sounds like you followed the directions on the can, which would be the correct way to SeaFoam a vehicle.

  3. #3

    Default

    You'd think that people would use the smoke as an indicator that it was working. Regardless of what your neighbors think about your smoking truck...

  4. #4

    Default

    Quote Originally Posted by cbroberts88 View Post
    You'd think that people would use the smoke as an indicator that it was working..
    Smoke doesn't mean it's working, just that it's burning.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #5
    Jr. Engineer BRB46's Avatar
    Join Date
    Apr 2011
    Location
    Western Mass
    Posts
    209

    Default

    Did you take it for a drive. When i did mine the same way it didn't smoke much at idle but when i left the driveway the neighbors thought my truck blew up.It lasted about half a mile at 40mph
    2006 Silverado 1500 5.3L ecsb Z71,afe pro s dry air filter, color matched tailgate handle and bezel,color matched front bow tie, led interior illumination, 5000K HID lows, Black powder coated wheels, Blacked out body side moldings, Rough Country 2.5" level/lift kit, Magnaflow muffler

  6. #6

    Default

    Quote Originally Posted by BRB46 View Post
    Did you take it for a drive. When i did mine the same way it didn't smoke much at idle but when i left the driveway the neighbors thought my truck blew up.It lasted about half a mile at 40mph
    I did take it for a drive and nothing...

    I seafoamed it again but this time work the spray through the throttle body. Sprayed am entire can through and then shut it off. Went to take a shower and did some laundry and waited about an hour before I started it back up. This time there was a little more smoke as I was driving around when I would accelerate. About 20 miles on I-75 driving "aggressively" I'd say it's all cleaned out.

  7. #7

    Default

    My understanding was complaints about SeaFoam centered around the smoke.
    personnaly smoke or no smoke I dont care I just want the product to do its job, but some do equate smoke with SeaFoam doing its job.

  8. #8

    Default

    Quote Originally Posted by tbplus10 View Post
    My understanding was complaints about SeaFoam centered around the smoke.
    personnaly smoke or no smoke I dont care I just want the product to do its job, but some do equate smoke with SeaFoam doing its job.
    Ok well that's good to know. I SeaFoamed it back to back so it should be nice and clean. I think I'm just going to give up and accept the fact that this truck is not going to give me the kind of mileage my 2011 Silverado gave me. Oh wells. More comfortable truck and still has all the capabilities that I want/need.

  9. #9
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,361

    Default

    My 08 Av with 102K now I use SF in the tank every 2 weeks and can notice the differance within 5 miles. I have not done plugs or wires yet...I put 1/2 a can in the gas and 1/2 in the oil 200 miles before a change..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  10. #10

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    My 08 Av with 102K now I use SF in the tank every 2 weeks and can notice the differance within 5 miles. I have not done plugs or wires yet...I put 1/2 a can in the gas and 1/2 in the oil 200 miles before a change..
    What difference do you notice and how big of a difference is it?

Page 1 of 2 12 Last Post byLast Post by

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •